[package] lua: the variable expansion to detect the host os does not work with GNU...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 28 Oct 2009 00:11:59 +0000 (00:11 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 28 Oct 2009 00:11:59 +0000 (00:11 +0000)
SVN-Revision: 18193

package/lua/Makefile

index 9d9c77b9e4fc1313e7f3cdb1bf09e75332214a00..c8c64badf47aa59c5569ca1cb8e992c5e8717d8a 100644 (file)
@@ -115,10 +115,15 @@ define Host/Configure
        $(SED) 's,"/usr/local/","$(STAGING_DIR_HOST)/",' $(HOST_BUILD_DIR)/src/luaconf.h
 endef
 
-LUA_OS.Darwin:=macosx
-LUA_OS.FreeBSD:=freebsd
-LUA_OS:=$(LUA_OS.$(HOST_OS))
-LUA_OS?=linux
+ifeq ($(HOST_OS),Darwin)
+       LUA_OS:=macosx
+else
+       ifeq ($(HOST_OS),FreeBSD)
+               LUA_OS:=freebsd
+       else
+               LUA_OS:=linux
+       endif
+endif
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) \