[packages] pciutils: Do not automatically update PCI IDs on real system
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 13 Apr 2011 17:40:10 +0000 (17:40 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 13 Apr 2011 17:40:10 +0000 (17:40 +0000)
SVN-Revision: 26649

utils/pciutils/Makefile

index fdf772f94790b586cbc1de79c2e1825dfb82f338..7b47f126efa54c427fbe63715204a44cd2b44a1f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
 PKG_VERSION:=3.1.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -34,6 +34,7 @@ endef
 
 define Package/pciutils/postinst
 #!/bin/sh
+[ -z "$${IPKG_INSTROOT}" ] || \
 (cd $${PKG_ROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-pciids; rm pci.ids.gz.old)
 exit 0
 endef