ar71xx: add profile and build image for TP-LINK TL-WA801N/ND
authorGabor Juhos <juhosg@openwrt.org>
Fri, 7 Dec 2012 19:10:56 +0000 (19:10 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 7 Dec 2012 19:10:56 +0000 (19:10 +0000)
Patch-by: Amir Sagie <openwrt-devel@taproot.org.il>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34576

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 07d7059a8c0de8b14a832c9580da8df6565599fd..a1018edad5109cc70c40c76999feb2490abdd2ca 100644 (file)
@@ -92,6 +92,16 @@ define Profile/TLWA7510/Description
 endef
 $(eval $(call Profile,TLWA7510))
 
+define Profile/TLWA801
+       NAME:=TP-LINK TL-WA801N/ND
+       PACKAGES:=
+endef
+
+define Profile/TLWA801/Description
+       Package set optimized for the TP-LINK TL-WA801N/ND.
+endef
+$(eval $(call Profile,TLWA801))
+
 
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
index f4d66b97ccb6e070cdebe7f5cfb1015c931ec494..b51e8c79f0a28b796aeef8838b44644b54a496ca 100644 (file)
@@ -852,6 +852,7 @@ $(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLMR3220,tl-mr3220-v1,TL-MR3220,
 $(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLMR3420,tl-mr3420-v1,TL-MR3420,ttyS0,115200,0x34200001,1,4M))
 $(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWA701,tl-wa701n-v1,TL-WA901ND,ttyS0,115200,0x07010001,1,4M))
 $(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWA7510NV1,tl-wa7510n,TL-WA7510N,ttyS0,115200,0x75100001,1,4M))
+$(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWA801NV1,tl-wa801nd-v1,TL-WA901ND,ttyS0,115200,0x08010001,1,4M))
 $(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWA901NV1,tl-wa901nd-v1,TL-WA901ND,ttyS0,115200,0x09010001,1,4M))
 $(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWA901NV2,tl-wa901nd-v2,TL-WA901ND-v2,ttyS0,115200,0x09010002,1,4M))
 $(eval $(call SingleProfile,TPLINK,$(fs_64kraw),TLWR740NV1,tl-wr740n-v1,TL-WR741ND,ttyS0,115200,0x07400001,1,4M))
@@ -915,6 +916,7 @@ $(eval $(call SingleProfile,ZyXEL,$(fs_64k),NBG_460N_550N_550NH,nbg460n_550n_550
 $(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
 $(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT))
 $(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
+$(eval $(call MultiProfile,TLWA801,TLWA801NV1))
 $(eval $(call MultiProfile,TLWA901,TLWA901NV1 TLWA901NV2))
 $(eval $(call MultiProfile,TLWA7510,TLWA7510NV1))
 $(eval $(call MultiProfile,TLWR740,TLWR740NV1 TLWR740NV3 TLWR740NV4))