Port setpwc to -ng
authorFlorian Fainelli <florian@openwrt.org>
Tue, 8 Aug 2006 12:25:46 +0000 (12:25 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 8 Aug 2006 12:25:46 +0000 (12:25 +0000)
SVN-Revision: 4530

utils/setpwc/Config.in [new file with mode: 0644]
utils/setpwc/Makefile [new file with mode: 0644]
utils/setpwc/ipkg/setpwc.control [new file with mode: 0644]

diff --git a/utils/setpwc/Config.in b/utils/setpwc/Config.in
new file mode 100644 (file)
index 0000000..19f32c6
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_SETPWC
+       prompt "setpwc............................ Philips (and compatibles) WebCams (PWC) control utility"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         Philips (and compatibles) WebCams (PWC) control utility.
+         
+         http://www.vanheusden.com/setpwc/
+
diff --git a/utils/setpwc/Makefile b/utils/setpwc/Makefile
new file mode 100644 (file)
index 0000000..7b2fd72
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=setpwc
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+PKG_MD5SUM:=a125d76f630c4aab940df5912f161965
+
+PKG_SOURCE_URL:=http://www.vanheusden.com/setpwc/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/setpwc
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Philips (and compatibles) WebCams (PWC) control utility
+  DESCRIPTION:=Philips (and compatibles) WebCams (PWC) control utility.
+  URL:=http://www.vanheusden.com/setpwc/
+endef
+
+
+define Build/Compile           
+       $(TARGET_CC) $(TARGET_CFLAGS) -DVERSION=\"$(PKG_VERSION)\" -o $(PKG_BUILD_DIR)/setpwc $(PKG_BUILD_DIR)/setpwc.c 
+endef
+
+define Package/setpwc/install  
+       install -d -m0755 $(1)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/setpwc $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,setpwc))
diff --git a/utils/setpwc/ipkg/setpwc.control b/utils/setpwc/ipkg/setpwc.control
new file mode 100644 (file)
index 0000000..1d7299a
--- /dev/null
@@ -0,0 +1,4 @@
+Package: setpwc
+Priority: optional
+Section: admin
+Description: Philips (and compatibles) WebCams (PWC) control utility