Port vnc-reflector to -ng
authorFlorian Fainelli <florian@openwrt.org>
Thu, 10 Aug 2006 22:08:41 +0000 (22:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 10 Aug 2006 22:08:41 +0000 (22:08 +0000)
SVN-Revision: 4558

net/vnc-reflector/Makefile [new file with mode: 0644]
net/vnc-reflector/patches/01-honor_include_lib_path.patch [new file with mode: 0644]

diff --git a/net/vnc-reflector/Makefile b/net/vnc-reflector/Makefile
new file mode 100644 (file)
index 0000000..b59fe44
--- /dev/null
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vnc-reflector
+PKG_VERSION:=1.2.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=c3f88bc62f228b335c25c07f9744ab0c
+
+PKG_SOURCE_URL:=@SF/vnc-reflector
+PKG_SOURCE:=vnc_reflector-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/vnc_reflector
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/vnc-reflector
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libjpeg
+  TITLE:=VNC proxy for multiple clients
+  DESCRIPTION:=VNC Reflector is a specialized VNC server which acts as\\\
+  a proxy sitting between real VNC server (a host) and a\\\
+  number of VNC clients. It was designed to work efficiently\\\
+  with large number of clients.\\\
+  URL:=http://sourceforge.net/projects/vnc-reflector
+endef
+
+define Build/Compile
+$(call Build/Compile/Default,CC="$(TARGET_CC)" \
+               OFLAGS="$(TARGET_CFLAGS)" \
+               STAGING_DIR=$(STAGING_DIR) \
+               default)
+endef
+
+define Package/vnc-reflector/install   
+       install -d -m0755 $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/vncreflector $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,vnc-reflector))
diff --git a/net/vnc-reflector/patches/01-honor_include_lib_path.patch b/net/vnc-reflector/patches/01-honor_include_lib_path.patch
new file mode 100644 (file)
index 0000000..fb409ac
--- /dev/null
@@ -0,0 +1,25 @@
+--- vnc_reflector/Makefile.orig        2005-12-14 01:25:53.000000000 +0100
++++ vnc_reflector/Makefile     2005-12-14 01:28:05.000000000 +0100
+@@ -14,10 +14,11 @@
+ #
+ # Variables you might want to edit: CFLAGS, CONFFLAGS
+-IFLAGS =      -I.
++IFLAGS =      -I. -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
++OFLAGS =      -O2
+ # Production
+-CFLAGS =      -O2 $(IFLAGS)
++CFLAGS =      $(OFLAGS) $(IFLAGS)
+ # Debug (strict)
+ #CFLAGS =     -g -pedantic -Wall $(IFLAGS)
+ # Debug (profiling)
+@@ -29,7 +30,7 @@
+ CONFFLAGS =   -DUSE_POLL
+ # Link with zlib and JPEG libraries
+-LDFLAGS =     -L/usr/local/lib -lz -ljpeg
++LDFLAGS =     -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lz -ljpeg
+ PROG =        vncreflector