automatic subtarget enumaration
authorJohn Crispin <john@openwrt.org>
Sun, 3 Jul 2011 17:38:23 +0000 (17:38 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 3 Jul 2011 17:38:23 +0000 (17:38 +0000)
SVN-Revision: 27407

include/target.mk
target/linux/lantiq/Makefile

index 676b983271b29220cb74dab61170b978c0792ec9..cfd7c9f3c345a239494b2852a443ecb4274d7267 100644 (file)
@@ -17,9 +17,6 @@ DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg hotplug2
 DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall
 DEFAULT_PACKAGES.bootloader:=
 
-# Add device specific packages
-DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
-
 ifneq ($(DUMP),)
   all: dumpinfo
 endif
@@ -30,6 +27,9 @@ ifeq ($(DUMP),)
   SUBTARGET:=$(strip $(foreach subdir,$(patsubst $(PLATFORM_DIR)/%/target.mk,%,$(wildcard $(PLATFORM_DIR)/*/target.mk)),$(if $(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(subdir))),$(subdir))))
 else
   PLATFORM_DIR:=${CURDIR}
+  ifeq ($(SUBTARGETS),)
+    SUBTARGETS:=$(strip $(patsubst $(PLATFORM_DIR)/%/target.mk,%,$(wildcard $(PLATFORM_DIR)/*/target.mk)))
+  endif
 endif
 
 TARGETID:=$(BOARD)$(if $(SUBTARGET),/$(SUBTARGET))
@@ -48,6 +48,9 @@ else
   endif
 endif
 
+# Add device specific packages (here below to allow device type set from subtarget)
+DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
+
 define Profile/Default
   NAME:=
   PACKAGES:=
index c09be31a6eee0604741a5b927c856ad360335a07..0f5064c3fc5f881549609f4e73a6eaf7b78a591e 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=lantiq
 BOARDNAME:=Lantiq GPON/XWAY
 FEATURES:=squashfs jffs2
-SUBTARGETS:=xway falcon ase
+#SUBTARGETS:=xway falcon ase
 
 LINUX_VERSION:=2.6.39.2