[packages] libcrypto++: remove manual autoreconf invocation, use default configure...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Jul 2011 02:16:20 +0000 (02:16 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Jul 2011 02:16:20 +0000 (02:16 +0000)
SVN-Revision: 27451

libs/libcrypto++/Makefile

index 5f97a23139d7f47e98afb8c679a1ddd38f919d12..8826d09613700f252dc504cc7bcbc58622a0646a 100644 (file)
@@ -15,7 +15,7 @@ PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/libc/libcrypto++/
 PKG_MD5SUM:=681f830145bf93cbc16113eaf61fbe2a
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -38,12 +38,8 @@ CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache GNUmakefile; autoreconf --force --install)
-       $(call Build/Configure/Default,,\
-               LDFLAGS="$(TARGET_LDFLAGS) -lpthread" \
-       )
-endef
+TARGET_LDFLAGS += \
+       -lpthread
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/crypto++