[ar7] refresh patches
authorFlorian Fainelli <florian@openwrt.org>
Thu, 28 May 2009 19:04:19 +0000 (19:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 28 May 2009 19:04:19 +0000 (19:04 +0000)
SVN-Revision: 16156

target/linux/ar7/patches-2.6.27/100-board_support.patch
target/linux/ar7/patches-2.6.27/110-flash.patch
target/linux/ar7/patches-2.6.27/120-gpio_chrdev.patch
target/linux/ar7/patches-2.6.27/130-vlynq.patch
target/linux/ar7/patches-2.6.27/150-cpmac_not_broken.patch
target/linux/ar7/patches-2.6.27/500-serial_kludge.patch
target/linux/ar7/patches-2.6.27/900-cpmac_multiqueue.patch
target/linux/generic-2.6/patches-2.6.27/801-usb_serial_endpoint_size.patch

index 2708f756578d5505753e193f5a4437aebb78551e..58bd909fbc2027cf5127720b35d1b96e1e2655e3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -18,6 +18,24 @@ choice
+@@ -19,6 +19,24 @@ choice
        prompt "System type"
        default SGI_IP22
  
        prompt "System type"
        default SGI_IP22
  
@@ -27,7 +27,7 @@
  
 --- a/arch/mips/kernel/traps.c
 +++ b/arch/mips/kernel/traps.c
  
 --- a/arch/mips/kernel/traps.c
 +++ b/arch/mips/kernel/traps.c
-@@ -1188,9 +1188,22 @@ void *set_except_vector(int n, void *add
+@@ -1203,9 +1203,22 @@ void *set_except_vector(int n, void *add
  
        exception_handlers[n] = handler;
        if (n == 0 && cpu_has_divec) {
  
        exception_handlers[n] = handler;
        if (n == 0 && cpu_has_divec) {
index 43e0c93fa94525a4045b907327da3de0ce49540c..60c7f335d5cb196c8c492b9021eebf73fcd628eb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -190,6 +190,12 @@ config MTD_MYLOADER_PARTS
+@@ -188,6 +188,12 @@ config MTD_MYLOADER_PARTS
          You will still need the parsing functions to be called by the driver
          for your particular device. It won't happen automatically.
  
          You will still need the parsing functions to be called by the driver
          for your particular device. It won't happen automatically.
  
@@ -15,7 +15,7 @@
  config MTD_CHAR
 --- a/drivers/mtd/maps/physmap.c
 +++ b/drivers/mtd/maps/physmap.c
  config MTD_CHAR
 --- a/drivers/mtd/maps/physmap.c
 +++ b/drivers/mtd/maps/physmap.c
-@@ -87,7 +87,7 @@ static int physmap_flash_remove(struct p
+@@ -85,7 +85,7 @@ static int physmap_flash_remove(struct p
  
  static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
  #ifdef CONFIG_MTD_PARTITIONS
  
  static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
  #ifdef CONFIG_MTD_PARTITIONS
index dfda2310e2246ad288484980221fb84361ff855c..5df86ee6dbc2e575d583d3e307846cec4e45aa30 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/char/Kconfig
 +++ b/drivers/char/Kconfig
 --- a/drivers/char/Kconfig
 +++ b/drivers/char/Kconfig
-@@ -960,6 +960,15 @@ config MWAVE
+@@ -968,6 +968,15 @@ config MWAVE
          To compile this driver as a module, choose M here: the
          module will be called mwave.
  
          To compile this driver as a module, choose M here: the
          module will be called mwave.
  
@@ -18,7 +18,7 @@
        depends on SCx200
 --- a/drivers/char/Makefile
 +++ b/drivers/char/Makefile
        depends on SCx200
 --- a/drivers/char/Makefile
 +++ b/drivers/char/Makefile
-@@ -91,6 +91,7 @@ obj-$(CONFIG_COBALT_LCD)     += lcd.o
+@@ -90,6 +90,7 @@ obj-$(CONFIG_HW_RANDOM)              += hw_random/
  obj-$(CONFIG_PPDEV)           += ppdev.o
  obj-$(CONFIG_NWBUTTON)                += nwbutton.o
  obj-$(CONFIG_NWFLASH)         += nwflash.o
  obj-$(CONFIG_PPDEV)           += ppdev.o
  obj-$(CONFIG_NWBUTTON)                += nwbutton.o
  obj-$(CONFIG_NWFLASH)         += nwflash.o
index 41940b3b537dc4b0988242c0d949065ea309bb20..9ab3638eaa18ff80e96264a5892c73f343a9f7e1 100644 (file)
  endmenu
 --- a/drivers/Makefile
 +++ b/drivers/Makefile
  endmenu
 --- a/drivers/Makefile
 +++ b/drivers/Makefile
-@@ -92,5 +92,6 @@ obj-$(CONFIG_DCA)            += dca/
+@@ -96,6 +96,7 @@ obj-$(CONFIG_DCA)            += dca/
  obj-$(CONFIG_HID)             += hid/
  obj-$(CONFIG_PPC_PS3)         += ps3/
  obj-$(CONFIG_OF)              += of/
 +obj-$(CONFIG_VLYNQ)           += vlynq/
  obj-$(CONFIG_SSB)             += ssb/
  obj-$(CONFIG_VIRTIO)          += virtio/
  obj-$(CONFIG_HID)             += hid/
  obj-$(CONFIG_PPC_PS3)         += ps3/
  obj-$(CONFIG_OF)              += of/
 +obj-$(CONFIG_VLYNQ)           += vlynq/
  obj-$(CONFIG_SSB)             += ssb/
  obj-$(CONFIG_VIRTIO)          += virtio/
+ obj-$(CONFIG_REGULATOR)               += regulator/
index 423a147de17cd6b86ccf9e828052c85233178610..e43369bdec006adbd5a4fc67367d821746298a10 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/Kconfig
 +++ b/drivers/net/Kconfig
 --- a/drivers/net/Kconfig
 +++ b/drivers/net/Kconfig
-@@ -1867,7 +1867,7 @@ config SC92031
+@@ -1823,7 +1823,7 @@ config SC92031
  
  config CPMAC
        tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)"
  
  config CPMAC
        tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)"
index 6ce59edf2cf4b4078f8da023c5365c00fe80bc8c..e7a4b24472f115381fa5e45f62bfa65f3b29c1f2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/serial/8250.c
 +++ b/drivers/serial/8250.c
 --- a/drivers/serial/8250.c
 +++ b/drivers/serial/8250.c
-@@ -266,6 +266,13 @@ static const struct serial8250_config ua
+@@ -264,6 +264,13 @@ static const struct serial8250_config ua
                .fcr            = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10,
                .flags          = UART_CAP_FIFO,
        },
                .fcr            = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10,
                .flags          = UART_CAP_FIFO,
        },
@@ -14,7 +14,7 @@
  };
  
  #if defined (CONFIG_SERIAL_8250_AU1X00)
  };
  
  #if defined (CONFIG_SERIAL_8250_AU1X00)
-@@ -2524,7 +2531,11 @@ static void serial8250_console_putchar(s
+@@ -2552,7 +2559,11 @@ static void serial8250_console_putchar(s
  {
        struct uart_8250_port *up = (struct uart_8250_port *)port;
  
  {
        struct uart_8250_port *up = (struct uart_8250_port *)port;
  
index 1484e2b5fda4e7828b1f102cebcd5c0362380351..c604aa4c3f56905773a26733d0a7c8648a1ae6c0 100644 (file)
@@ -19,7 +19,7 @@ because other drivers do it in the same way.
 
 --- a/drivers/net/cpmac.c
 +++ b/drivers/net/cpmac.c
 
 --- a/drivers/net/cpmac.c
 +++ b/drivers/net/cpmac.c
-@@ -621,13 +621,13 @@
+@@ -621,13 +621,13 @@ static void cpmac_end_xmit(struct net_de
  
                dev_kfree_skb_irq(desc->skb);
                desc->skb = NULL;
  
                dev_kfree_skb_irq(desc->skb);
                desc->skb = NULL;
@@ -35,7 +35,7 @@ because other drivers do it in the same way.
                        netif_wake_subqueue(dev, queue);
        }
  }
                        netif_wake_subqueue(dev, queue);
        }
  }
-@@ -737,7 +737,6 @@
+@@ -737,7 +737,6 @@ static void cpmac_clear_tx(struct net_de
  
  static void cpmac_hw_error(struct work_struct *work)
  {
  
  static void cpmac_hw_error(struct work_struct *work)
  {
@@ -43,7 +43,7 @@ because other drivers do it in the same way.
        struct cpmac_priv *priv =
                container_of(work, struct cpmac_priv, reset_work);
  
        struct cpmac_priv *priv =
                container_of(work, struct cpmac_priv, reset_work);
  
-@@ -824,7 +823,6 @@
+@@ -824,7 +823,6 @@ static irqreturn_t cpmac_irq(int irq, vo
  
  static void cpmac_tx_timeout(struct net_device *dev)
  {
  
  static void cpmac_tx_timeout(struct net_device *dev)
  {
@@ -51,7 +51,7 @@ because other drivers do it in the same way.
        struct cpmac_priv *priv = netdev_priv(dev);
  
        spin_lock(&priv->lock);
        struct cpmac_priv *priv = netdev_priv(dev);
  
        spin_lock(&priv->lock);
-@@ -1103,7 +1101,7 @@
+@@ -1103,7 +1101,7 @@ static int external_switch;
  
  static int __devinit cpmac_probe(struct platform_device *pdev)
  {
  
  static int __devinit cpmac_probe(struct platform_device *pdev)
  {
@@ -60,7 +60,7 @@ because other drivers do it in the same way.
        char *mdio_bus_id = "0";
        struct resource *mem;
        struct cpmac_priv *priv;
        char *mdio_bus_id = "0";
        struct resource *mem;
        struct cpmac_priv *priv;
-@@ -1132,6 +1130,7 @@
+@@ -1132,6 +1130,7 @@ static int __devinit cpmac_probe(struct 
        }
  
        dev = alloc_etherdev_mq(sizeof(*priv), CPMAC_QUEUES);
        }
  
        dev = alloc_etherdev_mq(sizeof(*priv), CPMAC_QUEUES);
index 78681d2b4a53ebf74edcca571bddb9ce83fc6a63..e96e01cd556da2ac7338661ef3b895b3aa36d3ac 100644 (file)
@@ -8,7 +8,7 @@
  static int debug;
  /* initially all NULL */
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
  static int debug;
  /* initially all NULL */
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
-@@ -856,7 +857,7 @@ int usb_serial_probe(struct usb_interfac
+@@ -835,7 +836,7 @@ int usb_serial_probe(struct usb_interfac
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1292,3 +1293,5 @@ MODULE_LICENSE("GPL");
+@@ -1255,3 +1256,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");