ar71xx: compress kernel binaries in Image/Prepare stage
authorGabor Juhos <juhosg@openwrt.org>
Tue, 31 Jan 2012 18:36:54 +0000 (18:36 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 31 Jan 2012 18:36:54 +0000 (18:36 +0000)
The lzma compressed kernel is used by one of the loaders.

SVN-Revision: 29971

target/linux/ar71xx/image/Makefile

index 43e74b243eca762bfbba45c3ea97255f1ffb1b5f..c3dc8a058d94381e3ea4c9183f36dcf8a6468e3b 100644 (file)
@@ -122,8 +122,6 @@ endef
 define Image/BuildKernel
        cp $(KDIR)/vmlinux.elf $(VMLINUX).elf
        cp $(KDIR)/vmlinux $(VMLINUX).bin
-       gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
-       $(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
        dd if=$(KDIR)/vmlinux.bin.lzma of=$(VMLINUX).lzma bs=65536 conv=sync
        dd if=$(KDIR)/vmlinux.bin.gz of=$(VMLINUX).gz bs=65536 conv=sync
        $(call MkuImage,gzip,,$(KDIR)/vmlinux.bin.gz,$(UIMAGE)-gzip.bin)
@@ -1064,6 +1062,8 @@ define Image/Build/Initramfs
 endef
 
 define Image/Prepare
+       gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
+       $(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
        $(call Image/Build/Profile/Default,loader)
 endef