Fix compilation, change rpl_malloc detection, closes #423
authorFlorian Fainelli <florian@openwrt.org>
Wed, 29 Mar 2006 11:55:40 +0000 (11:55 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 29 Mar 2006 11:55:40 +0000 (11:55 +0000)
SVN-Revision: 3543

openwrt/package/miau/Makefile

index b8290aa7b4636944ab55ee4dd3469802002a5e04..ecfb03d884efab09d2d1bc4b5543b887e75d4165 100644 (file)
@@ -24,6 +24,8 @@ $(PKG_BUILD_DIR)/.configured:
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ac_cv_func_malloc_0_nonnull=yes \
+               ac_cv_func_realloc_0_nonnull=yes \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \