quote LINUX_VERSION to avoid shell errors at DUMP time
authorNicolas Thill <nico@openwrt.org>
Sun, 16 Sep 2007 14:08:23 +0000 (14:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 16 Sep 2007 14:08:23 +0000 (14:08 +0000)
SVN-Revision: 8795

include/kernel-version.mk

index 508cf9934a5c72d0f4ae75d9e41b05067b4c281a..b504f7816d235ca17d655c3054e9733b1e27fa53 100644 (file)
@@ -21,5 +21,5 @@ endif
 LINUX_KERNEL_MD5SUM?=x
 
 KERNEL?=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
 LINUX_KERNEL_MD5SUM?=x
 
 KERNEL?=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
-KERNEL_PATCHVER=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)
+KERNEL_PATCHVER=$(shell echo '$(LINUX_VERSION)' | cut -d. -f1,2,3 | cut -d- -f1)