Create various profiles for consumer IXP4xx devices
authorRod Whitby <rod@whitby.id.au>
Fri, 29 Jun 2007 10:47:27 +0000 (10:47 +0000)
committerRod Whitby <rod@whitby.id.au>
Fri, 29 Jun 2007 10:47:27 +0000 (10:47 +0000)
SVN-Revision: 7774

target/linux/ixp4xx-2.6/profiles/100-Default.mk [new file with mode: 0644]
target/linux/ixp4xx-2.6/profiles/200-NSLU2.mk [new file with mode: 0644]
target/linux/ixp4xx-2.6/profiles/300-NAS100d.mk [new file with mode: 0644]
target/linux/ixp4xx-2.6/profiles/400-DSMG600RevA.mk [new file with mode: 0644]

diff --git a/target/linux/ixp4xx-2.6/profiles/100-Default.mk b/target/linux/ixp4xx-2.6/profiles/100-Default.mk
new file mode 100644 (file)
index 0000000..174267b
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  NAME:=Default Profile
+  PACKAGES:=
+endef
+
+define Profile/Default/Description
+       Default IXP4xx Profile
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/ixp4xx-2.6/profiles/200-NSLU2.mk b/target/linux/ixp4xx-2.6/profiles/200-NSLU2.mk
new file mode 100644 (file)
index 0000000..98be5e6
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NSLU2
+  NAME:=Linksys NSLU2
+  PACKAGES:=kmod-ixp4xx-npe kmod-usb2
+endef
+
+define Profile/NSLU2/Description
+       Package set optimized for the Linksys NSLU2
+endef
+$(eval $(call Profile,NSLU2))
+
diff --git a/target/linux/ixp4xx-2.6/profiles/300-NAS100d.mk b/target/linux/ixp4xx-2.6/profiles/300-NAS100d.mk
new file mode 100644 (file)
index 0000000..459fd2d
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NAS100d
+  NAME:=Iomega NAS 100d
+  PACKAGES:=kmod-ixp4xx-npe kmod-pata-artop madwifi kmod-usb2
+endef
+
+define Profile/NAS100d/Description
+       Package set optimized for the Iomega NAS 100d
+endef
+$(eval $(call Profile,NAS100d))
+
diff --git a/target/linux/ixp4xx-2.6/profiles/400-DSMG600RevA.mk b/target/linux/ixp4xx-2.6/profiles/400-DSMG600RevA.mk
new file mode 100644 (file)
index 0000000..e16ed0c
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DSMG600RevA
+  NAME:=DSM-G600 Rev A
+  PACKAGES:=kmod-via-velocity -kmod-ixp4xx-npe kmod-pata-artop madwifi kmod-usb2
+endef
+
+define Profile/DSMG600RevA/Description
+       Package set optimized for the DSM-G600 Rev A
+endef
+$(eval $(call Profile,DSMG600RevA))
+