merge mtd fis table changes from r17657-r17660 to 8.09 to provide a better upgrade...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 21 Sep 2009 12:38:22 +0000 (12:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 21 Sep 2009 12:38:22 +0000 (12:38 +0000)
SVN-Revision: 17662

package/mtd/Makefile
package/mtd/src/Makefile
package/mtd/src/fis.c [new file with mode: 0644]
package/mtd/src/fis.h [new file with mode: 0644]
package/mtd/src/jffs2.c
package/mtd/src/jffs2.h
package/mtd/src/mtd-api.h
package/mtd/src/mtd.c
target/linux/atheros/config-default
target/linux/atheros/files/drivers/mtd/devices/spiflash.c
target/linux/generic-2.6/patches-2.6.26/222-partial_eraseblock_write.patch [new file with mode: 0644]

index efb61d05909ea766d7156a7975818986b10e4f21..cf98609a497c8b887a4fc1d95b6873f34512ee77 100644 (file)
@@ -4,15 +4,15 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mtd
-PKG_RELEASE:=8.1
+PKG_RELEASE:=8.2
 
 PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
+STAMP_PREPARED := $(STAMP_PREPARED)_$(call confvar,CONFIG_MTD_REDBOOT_PARTS)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -34,12 +34,13 @@ endef
 
 target=$(firstword $(subst -, ,$(BOARD)))
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               TARGET=$(target) \
-               CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(target)=1 -Wall"
-endef
+MAKE_FLAGS += TARGET="$(target)"
+TARGET_CFLAGS += -Dtarget_$(target)=1 -Wall
+
+ifdef CONFIG_MTD_REDBOOT_PARTS
+  MAKE_FLAGS += FIS_SUPPORT=1
+  TARGET_CFLAGS += -DFIS_SUPPORT=1
+endif
 
 define Package/mtd/install
        $(INSTALL_DIR) $(1)/sbin
index 68a632d5ac73fd980f9f08a0e610256065205957..bb509be8ba261a8edf0d6662cd421e7eaf98baf1 100644 (file)
@@ -5,6 +5,10 @@ obj = mtd.o jffs2.o crc32.o
 obj.brcm = trx.o
 obj.brcm47xx = $(obj.brcm)
 
+ifdef FIS_SUPPORT
+  obj += fis.o
+endif
+
 mtd: $(obj) $(obj.$(TARGET))
 clean:
        rm -f *.o jffs2 
diff --git a/package/mtd/src/fis.c b/package/mtd/src/fis.c
new file mode 100644 (file)
index 0000000..f991019
--- /dev/null
@@ -0,0 +1,240 @@
+/*
+ * FIS table updating code for mtd
+ *
+ * Copyright (C) 2009 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License v2
+ * as published by the Free Software Foundation.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ */
+#include <sys/mman.h>
+#include <stdint.h>
+#include <stdlib.h>
+#include <string.h>
+#include <unistd.h>
+#include <stdio.h>
+#include "crc32.h"
+#include "mtd.h"
+#include "fis.h"
+
+struct fis_image_hdr {
+       unsigned char name[16];
+       uint32_t flash_base;
+       uint32_t mem_base;
+       uint32_t size;
+       uint32_t entry_point;
+       uint32_t data_length;
+} __attribute__((packed));
+
+struct fis_image_crc {
+       uint32_t desc;
+       uint32_t file;
+} __attribute__((packed));
+
+struct fis_image_desc {
+       struct fis_image_hdr hdr;
+       char _pad[256 - sizeof(struct fis_image_hdr) - sizeof(struct fis_image_crc)];
+       struct fis_image_crc crc;
+} __attribute__((packed));
+
+static int fis_fd = -1;
+static struct fis_image_desc *fis_desc;
+static int fis_erasesize = 0;
+
+static void
+fis_close(void)
+{
+       if (fis_desc)
+               munmap(fis_desc, fis_erasesize);
+
+       if (fis_fd >= 0)
+               close(fis_fd);
+
+       fis_fd = -1;
+       fis_desc = NULL;
+}
+
+static struct fis_image_desc *
+fis_open(void)
+{
+       struct fis_image_desc *desc;
+
+       if (fis_fd >= 0)
+               fis_close();
+
+       fis_fd = mtd_check_open("FIS directory");
+       if (fis_fd < 0)
+               goto error;
+
+       close(fis_fd);
+       fis_fd = mtd_open("FIS directory", true);
+       if (fis_fd < 0)
+               goto error;
+
+       fis_erasesize = erasesize;
+       desc = mmap(NULL, erasesize, PROT_READ|PROT_WRITE, MAP_SHARED, fis_fd, 0);
+       if (desc == MAP_FAILED)
+               goto error;
+
+       fis_desc = desc;
+       return desc;
+
+error:
+       fis_close();
+       return NULL;
+}
+
+int
+fis_validate(struct fis_part *old, int n_old, struct fis_part *new, int n_new)
+{
+       struct fis_image_desc *desc;
+       void *end;
+       int found = 0;
+       int i;
+
+       desc = fis_open();
+       if (!desc)
+               return 0;
+
+       for (i = 0; i < n_new - 1; i++) {
+               if (!new[i].size) {
+                       fprintf(stderr, "FIS error: only the last partition can detect the size automatically\n");
+                       i = -1;
+                       goto done;
+               }
+       }
+
+       end = desc;
+       end = (char *) end + fis_erasesize;
+       while ((void *) desc < end) {
+               if (!desc->hdr.name[0] || (desc->hdr.name[0] == 0xff))
+                       break;
+
+               for (i = 0; i < n_old; i++) {
+                       if (!strncmp((char *) desc->hdr.name, (char *) old[i].name, sizeof(desc->hdr.name))) {
+                               found++;
+                               goto next;
+                       }
+               }
+next:
+               desc++;
+               continue;
+       }
+
+       if (found == n_old)
+               i = 1;
+       else
+               i = -1;
+
+done:
+       fis_close();
+       return i;
+}
+
+int
+fis_remap(struct fis_part *old, int n_old, struct fis_part *new, int n_new)
+{
+       struct fis_image_desc *fisdir = NULL;
+       struct fis_image_desc *redboot = NULL;
+       struct fis_image_desc *first = NULL;
+       struct fis_image_desc *last = NULL;
+       struct fis_image_desc *desc;
+       struct fis_part *part;
+       uint32_t offset = 0, size = 0;
+       char *end, *tmp;
+       int i;
+
+       desc = fis_open();
+       if (!desc)
+               return -1;
+
+       if (!quiet)
+               fprintf(stderr, "Updating FIS table... \n");
+
+       end = (char *) desc + fis_erasesize;
+       while ((char *) desc < end) {
+               if (!desc->hdr.name[0] || (desc->hdr.name[0] == 0xff))
+                       break;
+
+               if (!strcmp((char *) desc->hdr.name, "FIS directory"))
+                       fisdir = desc;
+
+               if (!strcmp((char *) desc->hdr.name, "RedBoot"))
+                       redboot = desc;
+
+               for (i = 0; i < n_old; i++) {
+                       if (!strncmp((char *) desc->hdr.name, (char *) old[i].name, sizeof(desc->hdr.name))) {
+                               size += desc->hdr.size;
+                               last = desc;
+                               if (!first)
+                                       first = desc;
+                               break;
+                       }
+               }
+               desc++;
+       }
+       desc--;
+
+       if (desc == last) {
+               desc = fisdir;
+       }
+
+       /* size fixup */
+       if (desc && (last->hdr.flash_base < desc->hdr.flash_base - last->hdr.size))
+                       size += (desc->hdr.flash_base - last->hdr.flash_base) - last->hdr.size;
+
+#ifdef notyet
+       desc = first - 1;
+       if (redboot && (desc >= redboot)) {
+               if (first->hdr.flash_base - desc->hdr.size > desc->hdr.flash_base) {
+                       int delta = first->hdr.flash_base - desc->hdr.size - desc->hdr.flash_base;
+
+                       offset -= delta;
+                       size += delta;
+               }
+       }
+#endif
+
+       last++;
+       desc = first + n_new;
+       offset = first->hdr.flash_base;
+
+       if (desc != last) {
+               if (desc > last)
+                       tmp = (char *) desc;
+               else
+                       tmp = (char *) last;
+
+               memmove(desc, last, end - tmp);
+               if (desc < last) {
+                       tmp = end - (last - desc) * sizeof(struct fis_image_desc);
+                       memset(tmp, 0xff, tmp - end);
+               }
+       }
+
+       for (part = new, desc = first; desc < first + n_new; desc++, part++) {
+               memset(desc, 0, sizeof(struct fis_image_desc));
+               memcpy(desc->hdr.name, part->name, sizeof(desc->hdr.name));
+               desc->crc.desc = 0;
+               desc->crc.file = 0;
+
+               desc->hdr.flash_base = offset;
+               desc->hdr.mem_base = part->loadaddr;
+               desc->hdr.entry_point = part->loadaddr;
+               desc->hdr.size = (part->size > 0) ? part->size : size;
+               desc->hdr.data_length = desc->hdr.size;
+
+               offset += desc->hdr.size;
+               size -= desc->hdr.size;
+       }
+
+       msync(fis_desc, fis_erasesize, MS_SYNC|MS_INVALIDATE);
+       fis_close();
+
+       return 0;
+}
diff --git a/package/mtd/src/fis.h b/package/mtd/src/fis.h
new file mode 100644 (file)
index 0000000..bdf1103
--- /dev/null
@@ -0,0 +1,14 @@
+#ifndef __FIS_H
+#define __FIS_H
+
+struct fis_part {
+       unsigned char name[16];
+       uint32_t offset;
+       uint32_t loadaddr;
+       uint32_t size;
+};
+
+int fis_validate(struct fis_part *old, int n_old, struct fis_part *new, int n_new);
+int fis_remap(struct fis_part *old, int n_old, struct fis_part *new, int n_new);
+
+#endif
index c683b51d182f406d5328d4f886a8f65d74ac13d5..18eb4e686927a2ce56b4e3100e77b1a7f164e1b4 100644 (file)
@@ -1,3 +1,21 @@
+/*
+ * jffs2 on-disk structure generator for mtd
+ *
+ * Copyright (C) 2008 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License v2
+ * as published by the Free Software Foundation.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * Based on:
+ *   JFFS2 -- Journalling Flash File System, Version 2.
+ *   Copyright © 2001-2007 Red Hat, Inc.
+ *   Created by David Woodhouse <dwmw2@infradead.org>
+ */
 #include <sys/types.h>
 #include <sys/stat.h>
 #include <stdint.h>
index 70d46195348d9b3fc09e2fc047fa8b9e6d3c21cc..858e77a0173800fd6944a38eae3105d08182794f 100644 (file)
@@ -8,7 +8,6 @@
  * For licensing information, see the file 'LICENCE' in the
  * jffs2 directory.
  *
- * $Id: jffs2.h,v 1.38 2005/09/26 11:37:23 havasi Exp $
  *
  */
 
index 6ce62611e32fa343be233a6ff2f998ff55543c2d..272043ddb226ce9ff3ad9f817676b9e3736baafe 100644 (file)
@@ -1,5 +1,4 @@
 
-/* $Id: mtd.h,v 1.38 2003/01/12 16:30:19 spse Exp $ */
 
 #ifndef __MTD_MTD_H__
 #define __MTD_MTD_H__
index fb650a0da34b88558d6e66ab18f365251146a642..bd966ab7dca699a16aadcfdc61ab0fb88fdd427d 100644 (file)
@@ -1,13 +1,12 @@
 /*
  * mtd - simple memory technology device manipulation tool
  *
- * Copyright (C) 2005 Waldemar Brodkorb <wbx@dass-it.de>,
- *                       Felix Fietkau <nbd@openwrt.org>
+ * Copyright (C) 2005      Waldemar Brodkorb <wbx@dass-it.de>,
+ * Copyright (C) 2005-2009 Felix Fietkau <nbd@openwrt.org>
  *
  * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License
- * as published by the Free Software Foundation; either version 2
- * of the License, or (at your option) any later version.
+ * modify it under the terms of the GNU General Public License v2
+ * as published by the Free Software Foundation.
  *
  * This program is distributed in the hope that it will be useful,
  * but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -18,7 +17,6 @@
  * along with this program; if not, write to the Free Software
  * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
  *
- * $Id$
  *
  * The code is based on the linux-mtd examples.
  */
@@ -44,6 +42,7 @@
 #include <sys/reboot.h>
 #include <linux/reboot.h>
 #include "mtd-api.h"
+#include "fis.h"
 #include "mtd.h"
 
 #define MAX_ARGS 8
@@ -120,10 +119,9 @@ int mtd_erase_block(int fd, int offset)
        mtdEraseInfo.start = offset;
        mtdEraseInfo.length = erasesize;
        ioctl(fd, MEMUNLOCK, &mtdEraseInfo);
-       if (ioctl (fd, MEMERASE, &mtdEraseInfo) < 0) {
-               fprintf(stderr, "Erasing mtd failed.\n");
-               exit(1);
-       }
+       if (ioctl (fd, MEMERASE, &mtdEraseInfo) < 0)
+               return -1;
+
        return 0;
 }
 
@@ -147,42 +145,78 @@ image_check(int imagefd, const char *mtd)
 
 static int mtd_check(const char *mtd)
 {
+       char *next = NULL;
+       char *str = NULL;
        int fd;
 
-       fd = mtd_check_open(mtd);
-       if (!fd)
-               return 0;
+       if (strchr(mtd, ':')) {
+               str = strdup(mtd);
+               mtd = str;
+       }
 
-       if (!buf)
-               buf = malloc(erasesize);
+       do {
+               next = strchr(mtd, ':');
+               if (next) {
+                       *next = 0;
+                       next++;
+               }
+
+               fd = mtd_check_open(mtd);
+               if (!fd)
+                       return 0;
+
+               if (!buf)
+                       buf = malloc(erasesize);
+
+               close(fd);
+               mtd = next;
+       } while (next);
+
+       if (str)
+               free(str);
 
-       close(fd);
        return 1;
 }
 
 static int
 mtd_unlock(const char *mtd)
 {
-       int fd;
        struct erase_info_user mtdLockInfo;
+       char *next = NULL;
+       char *str = NULL;
+       int fd;
 
-       fd = mtd_check_open(mtd);
-       if(fd <= 0) {
-               fprintf(stderr, "Could not open mtd device: %s\n", mtd);
-               exit(1);
+       if (strchr(mtd, ':')) {
+               str = strdup(mtd);
+               mtd = str;
        }
 
-       if (quiet < 2) 
-               fprintf(stderr, "Unlocking %s ...\n", mtd);
+       do {
+               next = strchr(mtd, ':');
+               if (next) {
+                       *next = 0;
+                       next++;
+               }
+
+               fd = mtd_check_open(mtd);
+               if(fd <= 0) {
+                       fprintf(stderr, "Could not open mtd device: %s\n", mtd);
+                       exit(1);
+               }
 
-       mtdLockInfo.start = 0;
-       mtdLockInfo.length = mtdsize;
-       if(ioctl(fd, MEMUNLOCK, &mtdLockInfo)) {
+               if (quiet < 2)
+                       fprintf(stderr, "Unlocking %s ...\n", mtd);
+
+               mtdLockInfo.start = 0;
+               mtdLockInfo.length = mtdsize;
+               ioctl(fd, MEMUNLOCK, &mtdLockInfo);
                close(fd);
-               return 0;
-       }
-               
-       close(fd);
+               mtd = next;
+       } while (next);
+
+       if (str)
+               free(str);
+
        return 0;
 }
 
@@ -206,11 +240,11 @@ mtd_erase(const char *mtd)
        for (mtdEraseInfo.start = 0;
                 mtdEraseInfo.start < mtdsize;
                 mtdEraseInfo.start += erasesize) {
-               
+
                ioctl(fd, MEMUNLOCK, &mtdEraseInfo);
                if(ioctl(fd, MEMERASE, &mtdEraseInfo))
                        fprintf(stderr, "Failed to erase block on %s at 0x%x\n", mtd, mtdEraseInfo.start);
-       }               
+       }
 
        close(fd);
        return 0;
@@ -245,27 +279,99 @@ mtd_refresh(const char *mtd)
 }
 
 static int
-mtd_write(int imagefd, const char *mtd)
+mtd_write(int imagefd, const char *mtd, char *fis_layout)
 {
+       char *next = NULL;
+       char *str = NULL;
        int fd, result;
        ssize_t r, w, e;
+       uint32_t offset = 0;
+
+#ifdef FIS_SUPPORT
+       static struct fis_part new_parts[MAX_ARGS];
+       static struct fis_part old_parts[MAX_ARGS];
+       int n_new = 0, n_old = 0;
+
+       if (fis_layout) {
+               const char *tmp = mtd;
+               char *word, *brkt;
+               int ret;
+
+               memset(&old_parts, 0, sizeof(old_parts));
+               memset(&new_parts, 0, sizeof(new_parts));
+
+               do {
+                       next = strchr(tmp, ':');
+                       if (!next)
+                               next = (char *) tmp + strlen(tmp);
+
+                       memcpy(old_parts[n_old].name, tmp, next - tmp);
+
+                       n_old++;
+                       tmp = next + 1;
+               } while(*next);
+
+               for (word = strtok_r(fis_layout, ",", &brkt);
+                    word;
+                        word = strtok_r(NULL, ",", &brkt)) {
+
+                       tmp = strtok(word, ":");
+                       strncpy((char *) new_parts[n_new].name, tmp, sizeof(new_parts[n_new].name) - 1);
+
+                       tmp = strtok(NULL, ":");
+                       if (!tmp)
+                               goto next;
+
+                       new_parts[n_new].size = strtoul(tmp, NULL, 0);
+
+                       tmp = strtok(NULL, ":");
+                       if (!tmp)
+                               goto next;
+
+                       new_parts[n_new].loadaddr = strtoul(tmp, NULL, 16);
+next:
+                       n_new++;
+               }
+               ret = fis_validate(old_parts, n_old, new_parts, n_new);
+               if (ret < 0) {
+                       fprintf(stderr, "Failed to validate the new FIS partition table\n");
+                       exit(1);
+               }
+               if (ret == 0)
+                       fis_layout = NULL;
+       }
+#endif
+
+       if (strchr(mtd, ':')) {
+               str = strdup(mtd);
+               mtd = str;
+       }
+
+       r = 0;
+
+resume:
+       next = strchr(mtd, ':');
+       if (next) {
+               *next = 0;
+               next++;
+       }
 
        fd = mtd_check_open(mtd);
        if(fd < 0) {
                fprintf(stderr, "Could not open mtd device: %s\n", mtd);
                exit(1);
        }
-               
+
        if (quiet < 2)
                fprintf(stderr, "Writing from %s to %s ... ", imagefile, mtd);
 
-       r = w = e = 0;
+       w = e = 0;
        if (!quiet)
                fprintf(stderr, " [ ]");
 
        for (;;) {
-               /* buffer may contain data already (from trx check) */
-               do {
+               /* buffer may contain data already (from trx check or last mtd partition write attempt) */
+               while (buflen < erasesize) {
                        r = read(imagefd, buf + buflen, erasesize - buflen);
                        if (r < 0) {
                                if ((errno == EINTR) || (errno == EAGAIN))
@@ -280,7 +386,7 @@ mtd_write(int imagefd, const char *mtd)
                                break;
 
                        buflen += r;
-               } while (buflen < erasesize);
+               }
 
                if (buflen == 0)
                        break;
@@ -305,16 +411,33 @@ mtd_write(int imagefd, const char *mtd)
                        if (!quiet)
                                fprintf(stderr, "\b\b\b[e]");
 
-                       mtd_erase_block(fd, e);
+
+                       if (mtd_erase_block(fd, e) < 0) {
+                               if (next) {
+                                       if (w < e) {
+                                               write(fd, buf + offset, e - w);
+                                               offset = e - w;
+                                       }
+                                       w = 0;
+                                       e = 0;
+                                       close(fd);
+                                       mtd = next;
+                                       fprintf(stderr, "\b\b\b   \n");
+                                       goto resume;
+                               } else {
+                                       fprintf(stderr, "Failed to erase block\n");
+                                       exit(1);
+                               }
+                       }
 
                        /* erase the chunk */
                        e += erasesize;
                }
-               
+
                if (!quiet)
                        fprintf(stderr, "\b\b\b[w]");
-               
-               if ((result = write(fd, buf, buflen)) < buflen) {
+
+               if ((result = write(fd, buf + offset, buflen)) < buflen) {
                        if (result < 0) {
                                fprintf(stderr, "Error writing image.\n");
                                exit(1);
@@ -326,21 +449,30 @@ mtd_write(int imagefd, const char *mtd)
                w += buflen;
 
                buflen = 0;
+               offset = 0;
        }
+
        if (!quiet)
-               fprintf(stderr, "\b\b\b\b");
+               fprintf(stderr, "\b\b\b\b    ");
 
 done:
        if (quiet < 2)
                fprintf(stderr, "\n");
 
+#ifdef FIS_SUPPORT
+       if (fis_layout) {
+               if (fis_remap(old_parts, n_old, new_parts, n_new) < 0)
+                       fprintf(stderr, "Failed to update the FIS partition table\n");
+       }
+#endif
+
        close(fd);
        return 0;
 }
 
 static void usage(void)
 {
-       fprintf(stderr, "Usage: mtd [<options> ...] <command> [<arguments> ...] <device>\n\n"
+       fprintf(stderr, "Usage: mtd [<options> ...] <command> [<arguments> ...] <device>[:<device>...]\n\n"
        "The device is in the format of mtdX (eg: mtd4) or its label.\n"
        "mtd recognizes these commands:\n"
        "        unlock                  unlock the device\n"
@@ -356,6 +488,12 @@ static void usage(void)
        "        -e <device>             erase <device> before executing the command\n"
        "        -d <name>               directory for jffs2write, defaults to \"tmp\"\n"
        "        -j <name>               integrate <file> into jffs2 data when writing an image\n"
+#ifdef FIS_SUPPORT
+       "        -F <part>[:<size>[:<entrypoint>]][,<part>...]\n"
+       "                                alter the fis partition table to create new partitions replacing\n"
+       "                                the partitions provided as argument to the write command\n"
+       "                                (only valid together with the write command)\n"
+#endif
        "\n"
        "Example: To write linux.trx to mtd4 labeled as linux and reboot afterwards\n"
        "         mtd -r write linux.trx linux\n\n");
@@ -379,6 +517,7 @@ int main (int argc, char **argv)
 {
        int ch, i, boot, imagefd = 0, force, unlocked;
        char *erase[MAX_ARGS], *device = NULL;
+       char *fis_layout = NULL;
        enum {
                CMD_ERASE,
                CMD_WRITE,
@@ -386,14 +525,18 @@ int main (int argc, char **argv)
                CMD_REFRESH,
                CMD_JFFS2WRITE
        } cmd = -1;
-       
+
        erase[0] = NULL;
        boot = 0;
        force = 0;
        buflen = 0;
        quiet = 0;
 
-       while ((ch = getopt(argc, argv, "frqe:d:j:")) != -1)
+       while ((ch = getopt(argc, argv,
+#ifdef FIS_SUPPORT
+                       "F:"
+#endif
+                       "frqe:d:j:")) != -1)
                switch (ch) {
                        case 'f':
                                force = 1;
@@ -411,20 +554,25 @@ int main (int argc, char **argv)
                                i = 0;
                                while ((erase[i] != NULL) && ((i + 1) < MAX_ARGS))
                                        i++;
-                                       
+
                                erase[i++] = optarg;
                                erase[i] = NULL;
                                break;
                        case 'd':
                                jffs2dir = optarg;
                                break;
+#ifdef FIS_SUPPORT
+                       case 'F':
+                               fis_layout = optarg;
+                               break;
+#endif
                        case '?':
                        default:
                                usage();
                }
        argc -= optind;
        argv += optind;
-       
+
        if (argc < 2)
                usage();
 
@@ -440,7 +588,7 @@ int main (int argc, char **argv)
        } else if ((strcmp(argv[0], "write") == 0) && (argc == 3)) {
                cmd = CMD_WRITE;
                device = argv[2];
-       
+
                if (strcmp(argv[1], "-") == 0) {
                        imagefile = "<stdin>";
                        imagefd = 0;
@@ -451,7 +599,7 @@ int main (int argc, char **argv)
                                exit(1);
                        }
                }
-       
+
                if (!mtd_check(device)) {
                        fprintf(stderr, "Can't open device for writing!\n");
                        exit(1);
@@ -464,7 +612,7 @@ int main (int argc, char **argv)
        } else if ((strcmp(argv[0], "jffs2write") == 0) && (argc == 3)) {
                cmd = CMD_JFFS2WRITE;
                device = argv[2];
-       
+
                imagefile = argv[1];
                if (!mtd_check(device)) {
                        fprintf(stderr, "Can't open device for writing!\n");
@@ -475,7 +623,7 @@ int main (int argc, char **argv)
        }
 
        sync();
-       
+
        i = 0;
        unlocked = 0;
        while (erase[i] != NULL) {
@@ -485,8 +633,7 @@ int main (int argc, char **argv)
                        unlocked = 1;
                i++;
        }
-       
-               
+
        switch (cmd) {
                case CMD_UNLOCK:
                        if (!unlocked)
@@ -500,7 +647,7 @@ int main (int argc, char **argv)
                case CMD_WRITE:
                        if (!unlocked)
                                mtd_unlock(device);
-                       mtd_write(imagefd, device);
+                       mtd_write(imagefd, device, fis_layout);
                        break;
                case CMD_JFFS2WRITE:
                        if (!unlocked)
@@ -513,7 +660,7 @@ int main (int argc, char **argv)
        }
 
        sync();
-       
+
        if (boot)
                do_reboot();
 
index 8ffd759ef8bb47470d75b0caa0ec0ea5210d11d5..72ed3870ae487a9c0eb058f3058cddc53ed3e1ad 100644 (file)
@@ -161,7 +161,7 @@ CONFIG_MTD_PHYSMAP_START=0x0
 # CONFIG_MTD_RAM is not set
 CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-3
 CONFIG_MTD_REDBOOT_PARTS=y
-CONFIG_MTD_REDBOOT_PARTS_READONLY=y
+# CONFIG_MTD_REDBOOT_PARTS_READONLY is not set
 # CONFIG_MTD_ROM is not set
 # CONFIG_MTD_SLRAM is not set
 CONFIG_MTD_SPIFLASH=y
index c4c2016d8b070ac1617b241c7e89aa97d5e0d4ea..3fd5422b0fa07965a03143781a31e1a12a9b31dd 100644 (file)
@@ -317,7 +317,7 @@ spiflash_erase (struct mtd_info *mtd,struct erase_info *instr)
        spiflash_done();
 
        instr->state = MTD_ERASE_DONE;
-       if (instr->callback) instr->callback (instr);
+       mtd_erase_callback(instr);
 
        return 0;
 }
diff --git a/target/linux/generic-2.6/patches-2.6.26/222-partial_eraseblock_write.patch b/target/linux/generic-2.6/patches-2.6.26/222-partial_eraseblock_write.patch
new file mode 100644 (file)
index 0000000..10f2194
--- /dev/null
@@ -0,0 +1,140 @@
+--- a/drivers/mtd/mtdpart.c
++++ b/drivers/mtd/mtdpart.c
+@@ -23,6 +23,8 @@
+ #include <linux/squashfs_fs.h>
+ #include <linux/root_dev.h>
++#define MTD_ERASE_PARTIAL     0x8000 /* partition only covers parts of an erase block */
++
+ /* Our partition linked list */
+ static LIST_HEAD(mtd_partitions);
+@@ -214,12 +216,56 @@ static int part_erase (struct mtd_info *
+               return -EROFS;
+       if (instr->addr >= mtd->size)
+               return -EINVAL;
++
++      instr->partial_start = false;
++      if (mtd->flags & MTD_ERASE_PARTIAL) {
++              size_t readlen = 0;
++              u32 mtd_ofs;
++
++              instr->erase_buf = kmalloc(part->master->erasesize, GFP_ATOMIC);
++              if (!instr->erase_buf)
++                      return -ENOMEM;
++
++              instr->erase_buf_ofs = (part->offset + instr->addr) %
++                      part->master->erasesize;
++
++              if (instr->erase_buf_ofs > 0) {
++                      instr->addr -= instr->erase_buf_ofs;
++                      ret = part->master->read(part->master,
++                              instr->addr + part->offset,
++                              part->master->erasesize,
++                              &readlen, instr->erase_buf);
++
++                      instr->partial_start = true;
++              } else {
++                      instr->erase_buf_ofs = part->master->erasesize -
++                              ((part->offset + part->mtd.size) % part->master->erasesize);
++
++                      if (instr->erase_buf_ofs > 0) {
++                              instr->len += instr->erase_buf_ofs;
++                              ret = part->master->read(part->master,
++                                      part->offset + instr->addr +
++                                      instr->len - part->master->erasesize,
++                                      part->master->erasesize, &readlen,
++                                      instr->erase_buf);
++                      } else {
++                              ret = 0;
++                      }
++              }
++              if (ret < 0) {
++                      kfree(instr->erase_buf);
++                      return ret;
++              }
++      }
+       instr->addr += part->offset;
+       ret = part->master->erase(part->master, instr);
++      instr->partial_start = false;
+       if (ret) {
+               if (instr->fail_addr != 0xffffffff)
+                       instr->fail_addr -= part->offset;
+               instr->addr -= part->offset;
++              if (mtd->flags & MTD_ERASE_PARTIAL)
++                      kfree(instr->erase_buf);
+       }
+       return ret;
+ }
+@@ -228,7 +274,25 @@ void mtd_erase_callback(struct erase_inf
+ {
+       if (instr->mtd->erase == part_erase) {
+               struct mtd_part *part = PART(instr->mtd);
++              size_t wrlen = 0;
++              if (instr->mtd->flags & MTD_ERASE_PARTIAL) {
++                      if (instr->partial_start) {
++                              part->master->write(part->master,
++                                      instr->addr, instr->erase_buf_ofs,
++                                      &wrlen, instr->erase_buf);
++                              instr->addr += instr->erase_buf_ofs;
++                      } else {
++                              instr->len -= instr->erase_buf_ofs;
++                              part->master->write(part->master,
++                                      instr->addr + instr->len,
++                                      instr->erase_buf_ofs, &wrlen,
++                                      instr->erase_buf +
++                                      part->master->erasesize -
++                                      instr->erase_buf_ofs);
++                      }
++                      kfree(instr->erase_buf);
++              }
+               if (instr->fail_addr != 0xffffffff)
+                       instr->fail_addr -= part->offset;
+               instr->addr -= part->offset;
+@@ -456,17 +520,24 @@ static int add_one_partition(struct mtd_
+       if ((slave->mtd.flags & MTD_WRITEABLE) &&
+           (slave->offset % slave->mtd.erasesize)) {
+               /* Doesn't start on a boundary of major erase size */
+-              /* FIXME: Let it be writable if it is on a boundary of _minor_ erase size though */
+-              slave->mtd.flags &= ~MTD_WRITEABLE;
+-              printk ("mtd: partition \"%s\" doesn't start on an erase block boundary -- force read-only\n",
+-                      part->name);
++              slave->mtd.flags |= MTD_ERASE_PARTIAL;
++              if (((u32) slave->mtd.size) > master->erasesize)
++                      slave->mtd.flags &= ~MTD_WRITEABLE;
++              else
++                      slave->mtd.erasesize = slave->mtd.size;
+       }
+       if ((slave->mtd.flags & MTD_WRITEABLE) &&
+           (slave->mtd.size % slave->mtd.erasesize)) {
+-              slave->mtd.flags &= ~MTD_WRITEABLE;
+-              printk ("mtd: partition \"%s\" doesn't end on an erase block -- force read-only\n",
+-                      part->name);
+-      }
++              slave->mtd.flags |= MTD_ERASE_PARTIAL;
++
++              if ((u32) slave->mtd.size > master->erasesize)
++                      slave->mtd.flags &= ~MTD_WRITEABLE;
++              else
++                      slave->mtd.erasesize = slave->mtd.size;
++      }
++      if ((slave->mtd.flags & (MTD_ERASE_PARTIAL|MTD_WRITEABLE)) == MTD_ERASE_PARTIAL)
++              printk(KERN_WARNING"mtd: partition \"%s\" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only\n",
++                              part->name);
+       slave->mtd.ecclayout = master->ecclayout;
+       if (master->block_isbad) {
+--- a/include/linux/mtd/mtd.h
++++ b/include/linux/mtd/mtd.h
+@@ -43,6 +43,10 @@ struct erase_info {
+       u_long priv;
+       u_char state;
+       struct erase_info *next;
++
++      u8 *erase_buf;
++      u32 erase_buf_ofs;
++      bool partial_start;
+ };
+ struct mtd_erase_region_info {