Install net-snmp-config into $(STAGING_DIR)/host/bin rather then
authorLars-Peter Clausen <lars@metafoo.de>
Wed, 8 Oct 2008 10:34:14 +0000 (10:34 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Wed, 8 Oct 2008 10:34:14 +0000 (10:34 +0000)
$(STAGING_DIR)/usr/bin. Fixes build of packages which depend on libnet-snmp like
collectd.

SVN-Revision: 12894

libs/net-snmp/Makefile

index f86a4e0ae98e5f0aeb82afdc5518fc60d9ea0c08..54ed1a3cc0c5081083cb3d4d05b0701b9ef99c6c 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -183,14 +183,14 @@ define Build/Compile
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/net-snmp-config $(1)/usr/bin/
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/net-snmp-config $(2)/bin/
+       $(SED) 's,=/usr,=$(STAGING_DIR)/usr,g' $(2)/bin/net-snmp-config
+
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/net-snmp $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/net-snmp $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.{a,so*} $(1)/usr/lib/
-       $(SED) 's,-I/usr/include,,g' $(1)/usr/bin/net-snmp-config
-       $(SED) 's,-L/usr/lib,,g' $(1)/usr/bin/net-snmp-config
 endef
 
 define Package/libnetsnmp/install
 endef
 
 define Package/libnetsnmp/install