[8.09] firewall: merge r17238, bump patch level
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 13 Aug 2009 03:35:36 +0000 (03:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 13 Aug 2009 03:35:36 +0000 (03:35 +0000)
SVN-Revision: 17239

package/firewall/Makefile
package/firewall/files/firewall.config

index ca301d65928456b1a93e3469adc973895685f970..20bda1a475c51380ea8729d387ac8286bb5ea53b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=1
-PKG_RELEASE:=1.1
+PKG_RELEASE:=1.2
 
 include $(INCLUDE_DIR)/package.mk
 
index 464540f9901cab71e2a49bc3fdbb72d14446ff6c..5a4b5af43657d3508e582b2bacea8893941d12c2 100644 (file)
@@ -22,6 +22,14 @@ config forwarding
        option dest     wan
        option mtu_fix  1
 
+# We need to accept udp packets on port 68,
+# see https://dev.openwrt.org/ticket/4108
+config rule
+       option src              wan
+       option proto            udp
+       option dest_port        68
+       option target           ACCEPT
+
 # include a file with users custom iptables rules
 config include
        option path /etc/firewall.user