[backfire] firewall: merge r28529
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 22 Oct 2011 21:38:55 +0000 (21:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 22 Oct 2011 21:38:55 +0000 (21:38 +0000)
SVN-Revision: 28530

package/firewall/Makefile
package/firewall/files/lib/core_rule.sh

index 79554f99ddf644ab81c25fc5b4bc1cb5c5ae4472..df49d1df787e170babd2404907064a8e00833ff2 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=34.2
+PKG_RELEASE:=34.3
 
 include $(INCLUDE_DIR)/package.mk
 
index de8cd8ea359b39eef25f6f0e5b6ea53c55814ef0..f49c42af55bf40407476e32948c091c202571c5e 100644 (file)
@@ -59,7 +59,7 @@ fw_load_rule() {
        fi
 
        local mode
-       fw_get_family_mode mode ${rule_family:-x} $rule_src I
+       fw_get_family_mode mode ${rule_family:-x} "$rule_src" I
 
        local src_spec dest_spec
        fw_get_negation src_spec '-s' "${rule_src_ip:+$rule_src_ip/$rule_src_ip_prefixlen}"