[lantiq] fixes none-pci build
authorJohn Crispin <john@openwrt.org>
Wed, 9 Jan 2013 09:04:09 +0000 (09:04 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 9 Jan 2013 09:04:09 +0000 (09:04 +0000)
SVN-Revision: 35062

target/linux/lantiq/patches-3.7/0302-wifi-eep.patch
target/linux/lantiq/patches-3.7/0303-vmmc.patch

index 65ec0d17b6c5e081adac482540a6346c8b2b76d9..54a8acd1edf9c53af408fe23cd5098c1a415e7ba 100644 (file)
@@ -2,10 +2,11 @@ Index: linux-3.7-rc8/arch/mips/lantiq/xway/Makefile
 ===================================================================
 --- linux-3.7-rc8.orig/arch/mips/lantiq/xway/Makefile  2012-12-13 10:59:54.176314899 +0100
 +++ linux-3.7-rc8/arch/mips/lantiq/xway/Makefile       2012-12-13 13:58:51.696584083 +0100
-@@ -1,3 +1,5 @@
+@@ -1,3 +1,6 @@
  obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
  
-+obj-y += ath_eep.o rt_eep.o eth_mac.o
++obj-y += eth_mac.o
++obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o
 +
  obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
 Index: linux-3.7-rc8/arch/mips/lantiq/xway/ath_eep.c
index f0bd584e38c7ab86afd2cea7bbaa22bef958dbde..4b5c280e822bb1b8d0faba5f1ea3ffe848b3afdc 100644 (file)
@@ -1,18 +1,19 @@
-Index: linux-3.7-rc8/arch/mips/lantiq/xway/Makefile
+Index: linux-3.7.1/arch/mips/lantiq/xway/Makefile
 ===================================================================
---- linux-3.7-rc8.orig/arch/mips/lantiq/xway/Makefile  2012-12-13 13:40:23.000000000 +0100
-+++ linux-3.7-rc8/arch/mips/lantiq/xway/Makefile       2012-12-13 13:40:49.788556963 +0100
-@@ -1,5 +1,5 @@
+--- linux-3.7.1.orig/arch/mips/lantiq/xway/Makefile    2013-01-09 09:30:35.000000000 +0100
++++ linux-3.7.1/arch/mips/lantiq/xway/Makefile 2013-01-09 09:33:03.932167465 +0100
+@@ -1,6 +1,6 @@
  obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
  
--obj-y += ath_eep.o rt_eep.o eth_mac.o
-+obj-y += ath_eep.o rt_eep.o eth_mac.o vmmc.o
+-obj-y += eth_mac.o
++obj-y += eth_mac.o vmmc.o
+ obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o
  
  obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
-Index: linux-3.7-rc8/arch/mips/lantiq/xway/vmmc.c
+Index: linux-3.7.1/arch/mips/lantiq/xway/vmmc.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7-rc8/arch/mips/lantiq/xway/vmmc.c 2012-12-13 13:40:30.520556476 +0100
++++ linux-3.7.1/arch/mips/lantiq/xway/vmmc.c   2013-01-09 09:31:49.264164272 +0100
 @@ -0,0 +1,63 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it