Add bmon, closes #765
authorFlorian Fainelli <florian@openwrt.org>
Mon, 9 Oct 2006 14:11:43 +0000 (14:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 9 Oct 2006 14:11:43 +0000 (14:11 +0000)
SVN-Revision: 4987

net/bmon/Makefile [new file with mode: 0644]

diff --git a/net/bmon/Makefile b/net/bmon/Makefile
new file mode 100644 (file)
index 0000000..1e0d75d
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 4603 2006-08-18 21:21:06Z mbm $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bmon
+PKG_VERSION:=2.1.0
+PKG_RELEASE:=0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://people.suug.ch/~tgr/bmon/files/
+PKG_MD5SUM:=3111a027907016c0902d67350c619df6
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bmon
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libncurses
+  TITLE:=bmon is a portable bandwidth monitor
+  DESCRIPTION:=\
+       bmon is a portable bandwidth monitor\\\
+       and rate estimator running on various\\\
+       operating systems. It supports various\\\
+       input methods for different architectures.
+  URL:=http://people.suug.ch/~tgr/bmon/
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --disable-cnt-workaroun \
+               --disable-rrd \
+               --disable-asoun \
+       )
+endef
+
+
+define Build/Compile
+$(call Build/Compile/Default,all)
+endef
+
+define Package/bmon/install
+       install -d -m0755 $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,bmon))