package/kernel: enable CONFIG_SND_SOC_DMAENGINE_PCM in sound-soc-core
authorFlorian Fainelli <florian@openwrt.org>
Mon, 10 Dec 2012 21:05:32 +0000 (21:05 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 10 Dec 2012 21:05:32 +0000 (21:05 +0000)
This is required for 3.6+ kernels and some sound SoC modules.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34618

package/kernel/modules/sound.mk

index 6f83701dfc26a383ae63fcac7eb5ba3d3687d2e5..f80fa36c01e39d559c8b08805f6863da6c5cd9ba 100644 (file)
@@ -149,6 +149,7 @@ define KernelPackage/sound-soc-core
   DEPENDS:=+kmod-regmap
   KCONFIG:= \
        CONFIG_SND_SOC \
+       CONFIG_SND_SOC_DMAENGINE_PCM=y \
        CONFIG_SND_SOC_ALL_CODECS=n
   FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
   AUTOLOAD:=$(call AutoLoad,55, snd-soc-core)