[packages] tinyproxy: update to 1.8.1
authorNicolas Thill <nico@openwrt.org>
Mon, 19 Apr 2010 05:44:20 +0000 (05:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 19 Apr 2010 05:44:20 +0000 (05:44 +0000)
SVN-Revision: 21018

net/tinyproxy/Makefile
net/tinyproxy/patches/010-no-docs-and-tests.patch
net/tinyproxy/patches/120-fix_INET6.patch

index 7d69c5a6b666c7f25adfe7c61cfb95a65988937c..50a23ab2728cdfcad3460902d3cc85698877fbfb 100644 (file)
@@ -8,22 +8,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
-PKG_VERSION:=1.8.0
+PKG_VERSION:=1.8.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
-PKG_MD5SUM:=09843d47828261394d0a30af0b058997
+PKG_MD5SUM:=e1f0977592f020ef509262c24c3284fb
 
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tinyproxy
+  SUBMENU:=Proxy Servers
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Proxy Servers
-  TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy.
+  TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy
   URL:=http://tinyproxy.sourceforge.net/
 endef
 
@@ -31,17 +31,14 @@ define Package/tinyproxy/conffiles
 /etc/config/tinyproxy
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-filter \
-               --enable-transparent \
-               --enable-regexcheck=no \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --enable-filter \
+       --enable-transparent \
+       --disable-regexcheck \
 
 define Package/tinyproxy/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/share/tinyproxy
        $(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
        $(INSTALL_DIR) $(1)/etc/config
index c1a003442864a08ff7e9c87028d8ba86ecdfb56e..b008971a418a560e85e751d5b49f3b694c952c2a 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/Makefile.am b/Makefile.am
-index 7de41f2..9d1f99b 100644
 --- a/Makefile.am
 +++ b/Makefile.am
 @@ -2,9 +2,7 @@ SUBDIRS = \
@@ -12,8 +10,6 @@ index 7de41f2..9d1f99b 100644
  
  # tools want this on a single line
  ACLOCAL_AMFLAGS = -I m4macros
-diff --git a/Makefile.in b/Makefile.in
-index d0ec918..5be49d4 100644
 --- a/Makefile.in
 +++ b/Makefile.in
 @@ -221,9 +221,7 @@ SUBDIRS = \
@@ -26,11 +22,9 @@ index d0ec918..5be49d4 100644
  
  
  # tools want this on a single line
-diff --git a/configure b/configure
-index 01d6883..facfadd 100755
 --- a/configure
 +++ b/configure
-@@ -9012,67 +9012,8 @@ $as_echo "$as_me: error: Your system's regexec() function is broken." >&2;}
+@@ -9012,67 +9012,8 @@ $as_echo "$as_me: error: Your system's r
  fi
  
  
index 0853cfeae41e4586b7bc1b791a0b61de2b829c4a..1c2683551afd4014b661a99002f5f135acf77c5b 100644 (file)
@@ -10,7 +10,7 @@
  {
          struct addrinfo hints, *res, *ressave;
  
-@@ -48,7 +47,7 @@ bind_socket (int sockfd, const char *addr, int family)
+@@ -48,7 +47,7 @@ bind_socket (int sockfd, const char *add
          assert (addr != NULL && strlen (addr) != 0);
  
          memset (&hints, 0, sizeof (struct addrinfo));
@@ -19,7 +19,7 @@
          hints.ai_socktype = SOCK_STREAM;
  
          /* The local port it not important */
-@@ -106,14 +105,12 @@ int opensock (const char *host, int port, const char *bind_to)
+@@ -106,14 +105,12 @@ int opensock (const char *host, int port
  
                  /* Bind to the specified address */
                  if (bind_to) {