[amazon] refresh kernel patches
authorGabor Juhos <juhosg@openwrt.org>
Mon, 19 May 2008 06:34:16 +0000 (06:34 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 19 May 2008 06:34:16 +0000 (06:34 +0000)
SVN-Revision: 11194

target/linux/amazon/patches/017-wdt-driver.patch
target/linux/amazon/patches/100-board.patch
target/linux/amazon/patches/110-char_drivers.patch
target/linux/amazon/patches/130-mtd_drivers.patch
target/linux/amazon/patches/140-net_drivers.patch
target/linux/amazon/patches/150-serial_driver.patch
target/linux/amazon/patches/160-cfi-swap.patch

index b915ebe5156db9aab22f5df6b55312e233742207..fa52fcb861a303a584ef8ddbbffd241decbc04be 100644 (file)
@@ -1,6 +1,8 @@
---- linux-2.6.21.5/drivers/char/watchdog/Makefile.orig 2007-08-05 11:13:29.177013987 +0200
-+++ linux-2.6.21.5/drivers/char/watchdog/Makefile      2007-08-05 11:13:52.190325445 +0200
-@@ -74,6 +74,7 @@
+Index: linux-2.6.21.7/drivers/char/watchdog/Makefile
+===================================================================
+--- linux-2.6.21.7.orig/drivers/char/watchdog/Makefile
++++ linux-2.6.21.7/drivers/char/watchdog/Makefile
+@@ -74,6 +74,7 @@ obj-$(CONFIG_WATCHDOG_RTAS) += wdrtas.o
  # MIPS Architecture
  obj-$(CONFIG_INDYDOG) += indydog.o
  obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
index 9b29141239591ebfb46052d311005630092c1c48..0293b04b57c9af7ce88e7aca21b2fc987b1ceeba 100644 (file)
@@ -1,7 +1,8 @@
-diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
---- linux.old/arch/mips/Kconfig        2007-02-02 23:55:52.912446784 +0100
-+++ linux.dev/arch/mips/Kconfig        2007-02-03 21:50:25.262027104 +0100
-@@ -145,6 +145,17 @@
+Index: linux-2.6.21.7/arch/mips/Kconfig
+===================================================================
+--- linux-2.6.21.7.orig/arch/mips/Kconfig
++++ linux-2.6.21.7/arch/mips/Kconfig
+@@ -159,6 +159,17 @@ config BASLER_EXCITE_PROTOTYPE
          note that a kernel built with this option selected will not be
          able to run on normal units.
  
@@ -19,7 +20,7 @@ diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
  config MIPS_COBALT
        bool "Cobalt Server"
        select DMA_NONCOHERENT
-@@ -766,6 +776,7 @@
+@@ -823,6 +834,7 @@ config TOSHIBA_RBTX4938
  
  endchoice
  
@@ -27,10 +28,11 @@ diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
  source "arch/mips/ddb5xxx/Kconfig"
  source "arch/mips/gt64120/ev64120/Kconfig"
  source "arch/mips/jazz/Kconfig"
-diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
---- linux.old/arch/mips/Makefile       2007-02-02 23:55:52.913446632 +0100
-+++ linux.dev/arch/mips/Makefile       2007-02-03 17:40:29.193776000 +0100
-@@ -267,6 +267,13 @@
+Index: linux-2.6.21.7/arch/mips/Makefile
+===================================================================
+--- linux-2.6.21.7.orig/arch/mips/Makefile
++++ linux-2.6.21.7/arch/mips/Makefile
+@@ -267,6 +267,13 @@ libs-$(CONFIG_MIPS_XXS1500)       += arch/mips
  load-$(CONFIG_MIPS_XXS1500)   += 0xffffffff80100000
  
  #
@@ -44,10 +46,11 @@ diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
  # Cobalt Server
  #
  core-$(CONFIG_MIPS_COBALT)    += arch/mips/cobalt/
-diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/bootinfo.h
---- linux.old/include/asm-mips/bootinfo.h      2007-02-02 23:55:52.913446632 +0100
-+++ linux.dev/include/asm-mips/bootinfo.h      2007-02-03 17:51:02.531494032 +0100
-@@ -212,6 +212,12 @@
+Index: linux-2.6.21.7/include/asm-mips/bootinfo.h
+===================================================================
+--- linux-2.6.21.7.orig/include/asm-mips/bootinfo.h
++++ linux-2.6.21.7/include/asm-mips/bootinfo.h
+@@ -213,6 +213,12 @@
  #define MACH_GROUP_NEC_EMMA2RH 25     /* NEC EMMA2RH (was 23)         */
  #define  MACH_NEC_MARKEINS    0       /* NEC EMMA2RH Mark-eins        */
  
@@ -60,4 +63,3 @@ diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/booti
  #define CL_SIZE                       COMMAND_LINE_SIZE
  
  const char *get_system_type(void);
-
index 73949646ffad82f77428ad30bc3225fcea9b2d3e..dd08498998f1d23abe488d1c30140e107176cd93 100644 (file)
@@ -1,8 +1,8 @@
-Index: linux-2.6.21.5/drivers/char/Makefile
+Index: linux-2.6.21.7/drivers/char/Makefile
 ===================================================================
---- linux-2.6.21.5.orig/drivers/char/Makefile  2007-06-24 07:44:10.606341712 +0200
-+++ linux-2.6.21.5/drivers/char/Makefile       2007-06-24 07:44:46.633864696 +0200
-@@ -103,6 +103,7 @@
+--- linux-2.6.21.7.orig/drivers/char/Makefile
++++ linux-2.6.21.7/drivers/char/Makefile
+@@ -103,6 +103,7 @@ obj-$(CONFIG_IPMI_HANDLER) += ipmi/
  
  obj-$(CONFIG_HANGCHECK_TIMER) += hangcheck-timer.o
  obj-$(CONFIG_TCG_TPM)         += tpm/
index 31f81640d90c1fff5f32ffc39f750b103682f150..59735e429450b9d8f6f5e14ae4f520fb2f763ab9 100644 (file)
@@ -1,8 +1,8 @@
-Index: linux-2.6.21.5/drivers/mtd/maps/Makefile
+Index: linux-2.6.21.7/drivers/mtd/maps/Makefile
 ===================================================================
---- linux-2.6.21.5.orig/drivers/mtd/maps/Makefile      2007-06-24 07:55:22.138253344 +0200
-+++ linux-2.6.21.5/drivers/mtd/maps/Makefile   2007-06-24 07:56:58.207648576 +0200
-@@ -72,3 +72,4 @@
+--- linux-2.6.21.7.orig/drivers/mtd/maps/Makefile
++++ linux-2.6.21.7/drivers/mtd/maps/Makefile
+@@ -72,3 +72,4 @@ obj-$(CONFIG_MTD_PLATRAM)    += plat-ram.o
  obj-$(CONFIG_MTD_OMAP_NOR)    += omap_nor.o
  obj-$(CONFIG_MTD_MTX1)                += mtx-1_flash.o
  obj-$(CONFIG_MTD_TQM834x)     += tqm834x.o
index 65a0e446eda098746ad606147432d24fe98f157d..1f010e55514c3a55eb52789e93cc69af5decd538 100644 (file)
@@ -1,8 +1,8 @@
-Index: linux-2.6.21.5/drivers/net/Makefile
+Index: linux-2.6.21.7/drivers/net/Makefile
 ===================================================================
---- linux-2.6.21.5.orig/drivers/net/Makefile   2007-06-24 09:03:20.308277264 +0200
-+++ linux-2.6.21.5/drivers/net/Makefile        2007-06-24 09:05:13.560060376 +0200
-@@ -219,3 +219,5 @@
+--- linux-2.6.21.7.orig/drivers/net/Makefile
++++ linux-2.6.21.7/drivers/net/Makefile
+@@ -219,3 +219,5 @@ obj-$(CONFIG_NETCONSOLE) += netconsole.o
  obj-$(CONFIG_FS_ENET) += fs_enet/
  
  obj-$(CONFIG_NETXEN_NIC) += netxen/
index 802c5c2a53118bf56da215766591b8ffd0666a3c..45bb8f482444e3236a0c17cb60a417c0195edd27 100644 (file)
@@ -1,7 +1,7 @@
-Index: linux-2.6.21.5/drivers/serial/Makefile
+Index: linux-2.6.21.7/drivers/serial/Makefile
 ===================================================================
---- linux-2.6.21.5.orig/drivers/serial/Makefile        2007-06-24 10:51:45.005412992 +0200
-+++ linux-2.6.21.5/drivers/serial/Makefile     2007-06-24 10:51:54.885910928 +0200
+--- linux-2.6.21.7.orig/drivers/serial/Makefile
++++ linux-2.6.21.7/drivers/serial/Makefile
 @@ -5,6 +5,7 @@
  #
  
index 9e20f0560ca4566181bb62766e4eaad1173ea0d2..f9305fd88b2ee92c622ce1f86bec1038541d6822 100644 (file)
@@ -1,6 +1,8 @@
---- linux-2.6.21.5/drivers/mtd/chips/cfi_cmdset_0002.c 2007-07-23 23:15:50.403369508 +0200
-+++ linux-2.6.21.5.orig/drivers/mtd/chips/cfi_cmdset_0002.c    2007-07-23 23:26:43.028560499 +0200
-@@ -1007,7 +1007,9 @@
+Index: linux-2.6.21.7/drivers/mtd/chips/cfi_cmdset_0002.c
+===================================================================
+--- linux-2.6.21.7.orig/drivers/mtd/chips/cfi_cmdset_0002.c
++++ linux-2.6.21.7/drivers/mtd/chips/cfi_cmdset_0002.c
+@@ -1007,7 +1007,9 @@ static int __xipram do_write_oneword(str
        int ret = 0;
        map_word oldd;
        int retry_cnt = 0;
@@ -11,4 +13,3 @@
        adr += chip->start;
  
        spin_lock(chip->mutex);
-