[package] fix more std=gnu99 lua related packages
authorFlorian Fainelli <florian@openwrt.org>
Thu, 29 Oct 2009 18:19:06 +0000 (18:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 29 Oct 2009 18:19:06 +0000 (18:19 +0000)
SVN-Revision: 18211

mail/imapfilter/Makefile
net/prosody/Makefile

index e1d939bc46c5b6a90f53ba94c764b8ad3cfd1167..08a4997baddcbd7405f6e5d0e92afd8c3762d1fc 100644 (file)
@@ -49,7 +49,7 @@ define Build/Compile
                $(TARGET_CONFIGURE_OPTS) \
                INCDIRS="$(TARGET_CPPFLAGS)" \
                LIBDIRS="$(TARGET_LDFLAGS)" \
-               MYCFLAGS="$(TARGET_CFLAGS)" \
+               MYCFLAGS="$(TARGET_CFLAGS) -std=gnu99" \
                MYLDFLAGS="-lcrypt" 
 endef
 
index a8d59c902cefa2df291dabb84da7eab0715e2e07..7f88340333fab590f1064cf2650632f948325ab0 100644 (file)
@@ -50,7 +50,7 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default,\
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -std=gnu99" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                PREFIX="/usr" \