It adds libowfat (http://www.fefe.de/libowfat/) to OpenWRT and closes
authorTravis Kemen <thepeople@openwrt.org>
Tue, 23 Mar 2010 00:44:47 +0000 (00:44 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Tue, 23 Mar 2010 00:44:47 +0000 (00:44 +0000)
therefore (if accepted) https://dev.openwrt.org/ticket/6908.

Libowfat is a library that implements various C APIs suggested by D.J. Bernstein.
Also see http://cr.yp.to/software.html.

Signed-off-by: Oliver Ripka <olliwolli@gmail.com>
SVN-Revision: 20376

libs/libowfat/Makefile [new file with mode: 0644]

diff --git a/libs/libowfat/Makefile b/libs/libowfat/Makefile
new file mode 100644 (file)
index 0000000..1ffc7fb
--- /dev/null
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+LOWFAT_VERSION=0.28
+
+PKG_NAME:=libowfat
+PKG_VERSION:=$(LOWFAT_VERSION)
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://dl.fefe.de
+PKG_MD5SUM:=6bbee9a86506419657d87123b7a6f2c1
+
+include $(INCLUDE_DIR)/package.mk
+
+# set to 1 to enable debugging
+DEBUG=
+
+define Package/libowfat
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=reimplemented libdjb under GPL
+endef
+
+define Build/Configure
+endef
+
+TARGET_CFLAGS += $(FPIC)
+LOWFAT_MAKEOPTS = \
+               $(TARGET_CONFIGURE_OPTS) \
+               COPTS="$(TARGET_CFLAGS)" \
+               DEBUG="$(DEBUG)" \
+               VERSION="$(LOWFAT_VERSION)" \
+               CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
+               OS="Linux"
+
+# work around a nasty gcc bug
+ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
+  LOWFAT_MAKEOPTS += WOPTS=""
+endif
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) $(LOWFAT_MAKEOPTS)
+endef
+
+define Build/InstallDev
+       mkdir -p $(1)/usr/include/libowfat
+       $(CP) $(PKG_BUILD_DIR)/*.h $(1)/usr/include/libowfat
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/*.a $(1)/usr/lib
+endef
+
+$(eval $(call BuildPackage,libowfat))