xserver-xorg: Add n810 config
authorMichael Büsch <mb@bu3sch.de>
Sat, 11 Sep 2010 15:57:34 +0000 (15:57 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sat, 11 Sep 2010 15:57:34 +0000 (15:57 +0000)
SVN-Revision: 23005

Xorg/xorg/xserver/xorg-server/Makefile
Xorg/xorg/xserver/xorg-server/files/config.xorg/nokia_n810 [new file with mode: 0644]

index 41a9a808b6494b65ff7f617293f442ae7162a110..96dbc41de4aee18e7bbd94735f3929d6022a14ae 100644 (file)
@@ -35,6 +35,9 @@ endif
 ifeq ($(CONFIG_TARGET_s3c24xx),y)
   X_CONFIG=om_gta02
 endif
+ifeq ($(CONFIG_TARGET_omap24xx_n810-gui),y)
+  X_CONFIG=nokia_n810
+endif
 
 define Package/xorg/Default
   SECTION:=xorg-server
diff --git a/Xorg/xorg/xserver/xorg-server/files/config.xorg/nokia_n810 b/Xorg/xorg/xserver/xorg-server/files/config.xorg/nokia_n810
new file mode 100644 (file)
index 0000000..8c2b40b
--- /dev/null
@@ -0,0 +1,32 @@
+Section "InputDevice"
+       Identifier "Touchscreen"
+       Driver "tslib"
+       Option "CorePointer" "true"
+       Option "SendCoreEvents" "true"
+       Option "Device" "/dev/input/event1"
+       Option "Protocol" "Auto"
+       Option "Width" "800"
+       Option "Height" "480"
+EndSection
+
+Section "Monitor"
+       Identifier "InternalLCD"
+EndSection
+
+Section "Device"
+       Identifier "FramebufferDevice"
+       Driver "omapfb"
+       Option "fb" "/dev/fb0"
+EndSection
+
+Section "Screen"
+       Identifier "InternalScreen"
+       Device "FramebufferDevice"
+       Monitor "InternalLCD"
+EndSection
+
+Section "ServerLayout"
+       Identifier "DefaultLayout"
+       Screen "InternalScreen"
+       InputDevice "Touchscreen" "CorePointer"
+EndSection