hostapd: add preliminary wps script support (push-button only, does not handle multi...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 8 Jul 2010 18:36:17 +0000 (18:36 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 8 Jul 2010 18:36:17 +0000 (18:36 +0000)
SVN-Revision: 22100

package/hostapd/Makefile
package/hostapd/files/hostapd.sh
package/hostapd/files/wps-hotplug.sh [new file with mode: 0644]

index 4189922561b530033797f7f4607612b2b24fef8e..dcbe9e53a678684726dbfba9e2e6d5a67cd3337e 100644 (file)
@@ -294,8 +294,9 @@ Package/hostapd-mini/install = $(Package/hostapd/install)
 
 ifneq ($(LOCAL_TYPE),supplicant)
   define Package/hostapd-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/hotplug.d/button
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
+       $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
   endef
 endif
 
index fdb047be6a76518f058fc014a8d4d6ce4e229585..c4e91689da3597ad447ba7b5fb3a7e72c36b377e 100644 (file)
@@ -1,7 +1,7 @@
 hostapd_set_bss_options() {
        local var="$1"
        local vif="$2"
-       local enc wpa_group_rekey
+       local enc wpa_group_rekey wps_possible
 
        config_get enc "$vif" encryption
        config_get wpa_group_rekey "$vif" wpa_group_rekey
@@ -60,6 +60,7 @@ hostapd_set_bss_options() {
                        else
                                append "$var" "wpa_passphrase=$psk" "$N"
                        fi
+                       wps_possible=1
                ;;
                *wpa*)
                        # required fields? formats?
@@ -116,6 +117,14 @@ hostapd_set_bss_options() {
        config_get bridge "$vif" bridge
        config_get ieee80211d "$vif" ieee80211d
 
+       config_get_bool wps_pbc "$vif" wps_pushbutton 0
+       [ -n "$wps_possible" -a "$wps_pbc" -gt 0 ] && {
+               append "$var" "eap_server=1" "$N"
+               append "$var" "wps_state=2" "$N"
+               append "$var" "ap_setup_locked=1" "$N"
+               append "$var" "config_methods=push_button" "$N"
+       }
+
        append "$var" "ssid=$ssid" "$N"
        [ -n "$bridge" ] && append "$var" "bridge=$bridge" "$N"
        [ -n "$ieee80211d" ] && append "$var" "ieee80211d=$ieee80211d" "$N"
diff --git a/package/hostapd/files/wps-hotplug.sh b/package/hostapd/files/wps-hotplug.sh
new file mode 100644 (file)
index 0000000..b5376cc
--- /dev/null
@@ -0,0 +1,6 @@
+if [ "$ACTION" = "pressed" -a "$BUTTON" = "wps" ]; then
+       for dir in /var/run/hostapd-*; do
+               [ -d "$dir" ] || continue
+               hostapd_cli -p "$dir" wps_pbc
+       done
+fi