add a patch to use target optimization flags, change to build-dep on libjpeg, Makefil...
authorNicolas Thill <nico@openwrt.org>
Sat, 28 Oct 2006 20:48:00 +0000 (20:48 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 28 Oct 2006 20:48:00 +0000 (20:48 +0000)
SVN-Revision: 5323

multimedia/palantir/Makefile
multimedia/palantir/patches/01-opt_flags.patch [new file with mode: 0644]

index 25ed5c31b0c3704def7a7d534a72b4644e1ed80f..ccf3b0e34f38819e5091bc2815d78dfc8e235845 100644 (file)
@@ -11,23 +11,24 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=palantir
 PKG_VERSION:=2.6
 PKG_RELEASE:=1
 PKG_NAME:=palantir
 PKG_VERSION:=2.6
 PKG_RELEASE:=1
-PKG_MD5SUM:=8e4d20e7f7fad26d7447483c68894ace
 
 
-PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
+PKG_MD5SUM:=8e4d20e7f7fad26d7447483c68894ace
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+PKG_BUILDDEP:=libjpeg
 
 define Package/palantir
   SECTION:=multimedia
   CATEGORY:=Multimedia
 
 define Package/palantir
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libjpeg
   TITLE:=A multichannel interactive streaming solution
   TITLE:=A multichannel interactive streaming solution
-  DESCRIPTION:=Palantir is a Linux-based streaming system designed to transmit live\\\
-       video, audio and data over a TCP/IP network, as well as to control\\\
-       remote devices.\\\
+  DESCRIPTION:=\
+       Palantir is a Linux-based streaming system designed to transmit live \\\
+       video, audio and data over a TCP/IP network, as well as to control \\\
+       remote devices.
   URL:=http://www.fastpath.it/products/palantir/
 endef
 
   URL:=http://www.fastpath.it/products/palantir/
 endef
 
@@ -35,21 +36,22 @@ define Package/palantir/conffiles
 /etc/palantir.conf
 endef
 
 /etc/palantir.conf
 endef
 
+include $(INCLUDE_DIR)/package.mk
+
 export CPPFLAGS=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 export LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
 
 export CPPFLAGS=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 export LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
 
-include $(INCLUDE_DIR)/package.mk
-
 define Build/Compile   
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)/usr
        $(MAKE) -C $(PKG_BUILD_DIR)/server/libgsm \
                $(TARGET_CONFIGURE_OPTS) \
                CCINC="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
 define Build/Compile   
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)/usr
        $(MAKE) -C $(PKG_BUILD_DIR)/server/libgsm \
                $(TARGET_CONFIGURE_OPTS) \
                CCINC="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               COPTS="$(TARGET_CFLAGS)" \
                lib/libgsm.a
        $(MAKE) -C $(PKG_BUILD_DIR)/server \
                $(TARGET_CONFIGURE_OPTS) \
                lib/libgsm.a
        $(MAKE) -C $(PKG_BUILD_DIR)/server \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="-Wall -D_REENTRANT $(TARGET_CFLAGS)" \
+               COPTS="$(TARGET_CFLAGS)" \
                palantir
 endef
 
                palantir
 endef
 
diff --git a/multimedia/palantir/patches/01-opt_flags.patch b/multimedia/palantir/patches/01-opt_flags.patch
new file mode 100644 (file)
index 0000000..1dcb751
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN palantir-2.6-old/server/Makefile palantir-2.6-new/server/Makefile
+--- palantir-2.6-old/server/Makefile   2005-09-02 14:33:50.000000000 +0200
++++ palantir-2.6-new/server/Makefile   2006-10-27 23:53:10.000000000 +0200
+@@ -47,7 +47,7 @@
+ .PHONY : tools man
+-CFLAGS= -Wall -D_REENTRANT -O3 -g
++CFLAGS= -Wall -D_REENTRANT $(COPTS)
+ CC= gcc
+ libjpeg= -ljpeg
+diff -ruN palantir-2.6-old/server/libgsm/Makefile palantir-2.6-new/server/libgsm/Makefile
+--- palantir-2.6-old/server/libgsm/Makefile    2005-08-14 00:16:27.000000000 +0200
++++ palantir-2.6-new/server/libgsm/Makefile    2006-10-27 23:53:44.000000000 +0200
+@@ -51,7 +51,7 @@
+ endif
+ CC            += -ansi -pedantic
+-CCFLAGS       = -c -O2 -DNeedFunctionPrototypes=1
++CCFLAGS       = -c $(COPTS) -DNeedFunctionPrototypes=1
+ LD            = $(CC)