image: append-ubi: add optional UBI subpage size
authorFelix Fietkau <nbd@openwrt.org>
Sat, 7 Nov 2015 13:19:35 +0000 (13:19 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 7 Nov 2015 13:19:35 +0000 (13:19 +0000)
Signed-off-by: Claudio Leite <leitec@staticky.com>
SVN-Revision: 47411

include/image.mk

index a6ea8e5452a6b1d1f4f91910c800231fdb299b95..fd5e3f4b62a4ca2d092c124fc354c6dcc3661b87 100644 (file)
@@ -384,7 +384,8 @@ define Build/append-ubi
                $(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
                $(word 2,$^) \
                $@.tmp \
-               -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5
+               -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5 \
+               $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE))
        cat $@.tmp >> $@
        rm $@.tmp
 endef