move empty from net to utils, bump release number
authorNicolas Thill <nico@openwrt.org>
Tue, 25 Sep 2007 23:32:13 +0000 (23:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 25 Sep 2007 23:32:13 +0000 (23:32 +0000)
SVN-Revision: 9029

net/empty/Makefile [deleted file]
utils/empty/Makefile [new file with mode: 0644]

diff --git a/net/empty/Makefile b/net/empty/Makefile
deleted file mode 100644 (file)
index cd932a4..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=empty
-PKG_VERSION:=0.6.11b
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=@SF/empty
-PKG_MD5SUM:=fb2c06de44ba37ea98b0be8296b89953
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/empty
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=run applications under pseudo-terminal (PTY) sessions.
-  DESCRIPTION:=\
-       run applications under pseudo-terminal (PTY) sessions. Replace TCL/Expect with a simple tool\\\
-       and use your favorite shell (sh, bash, csh, tcsh, ksh, zsh, etc)
-  URL:=http://empty.sourceforge.net
-endef
-
-define Package/empty/install   
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,empty))
diff --git a/utils/empty/Makefile b/utils/empty/Makefile
new file mode 100644 (file)
index 0000000..05f1a61
--- /dev/null
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=empty
+PKG_VERSION:=0.6.11b
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=@SF/empty
+PKG_MD5SUM:=fb2c06de44ba37ea98b0be8296b89953
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/empty
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Run applications under pseudo-terminal sessions
+  URL:=http://empty.sourceforge.net
+endef
+
+define Package/empty/description
+ empty is an utility that provides an interface to execute and/or interact 
+ with processes under pseudo-terminal sessions (PTYs). This tool is 
+ definitely useful in programming of shell scripts designed to communicate 
+ with interactive programs like telnet, ssh, ftp, etc. In some cases, empty 
+ can be the simplest replacement for TCL/expect or other similar 
+ programming tools.
+endef
+
+define Package/empty/install   
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,empty))