[package] comgt: handle service mode for Huawai modems (#12039)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Aug 2012 15:59:24 +0000 (15:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Aug 2012 15:59:24 +0000 (15:59 +0000)
It seems that the comgt package does not handle the Huawei 3G USB dongle E176 correctly (and probably other Huawei dongles too). My dongle appears as ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem and 3G/UMTS
connections work well. However, no connection is established if only 2G/GPRS is available: the pppd chat script fails with NO CARRIER although the dongle is registered to the network (via 2G). As outlined in  this wiki or  this
blog, Huawei chips use the AT^SYSCFG command to set 2G or 3G mode, which is not implemented in comgt at the moment. Thus I wrote a patch for /lib/network/3g.sh which adds support for the "service" option in the network
configuration with Huawei dongles. By default (if no "service" option is specified) also 2G is used when 3G is unavailable. The Huawei dongle is detected analogously to other chips (the output of gcom -d /dev/ttyUSB0 -s
/etc/gcom/getcardinfo.gcom is scanned for huawei).

Some further information: The AT^SYSCFG command seems to be respected only once after the dongle is attached (or after the host is powered up). Resetting the dongle seems to render the serial port unusable in some cases.
However, the patch sets a useful mode by default which should cover most use cases (3G preferred, but 2G allowed) and if 3G-only or 2G-only mode is required the device can be power cycled.

SVN-Revision: 33212

package/comgt/Makefile
package/comgt/files/3g.sh

index adaaa4fe6462c842a36a3d3082e033e5a5c51052..ef0164ea35249c3db6428337c1e003c1bd0122c6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=9
+PKG_RELEASE:=19
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index b5da54c44d51a8e24bc791152ccb6819173f55a1..9e44d0665055a6da2481e36dd94da5093611508a 100644 (file)
@@ -52,6 +52,13 @@ proto_3g_setup() {
                                export MODE="AT_OPSYS=${CODE}"
                        elif echo "$cardinfo" | grep -q "Sierra Wireless"; then
                                SIERRA=1
+                       elif echo "$cardinfo" | grep -q huawei; then
+                               case "$service" in
+                                       umts_only) CODE="14,2";;
+                                       gprs_only) CODE="13,1";;
+                                       *) CODE="2,2";;
+                               esac
+                               export MODE="AT^SYSCFG=${CODE},3FFFFFFF,2,4"
                        fi
 
                        if [ -n "$pincode" ]; then