package/Makefile: Substituted deprecated -perm +mode with -perm /mode
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:44:13 +0000 (12:44 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:44:13 +0000 (12:44 +0000)
The find(1) -perm +mode is no longer supported and has been deprecated since
2005.

This could resolve #13855 ticket.

Signed-off-by: Rocco Folino <lordzen87@gmail.com>
SVN-Revision: 40927

package/Makefile

index e189e37043c117359083112e2fcfd979b9ecfbfb..1930d27cf8b31640ddf6aca8d6816312f81373d0 100644 (file)
@@ -26,7 +26,7 @@ ifdef CONFIG_USE_MKLIBS
   define mklibs
        rm -rf $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-out
        # first find all programs and add them to the mklibs list
-       find $(STAGING_DIR_ROOT) -type f -perm +100 -exec \
+       find $(STAGING_DIR_ROOT) -type f -perm /100 -exec \
                file -r -N -F '' {} + | \
                awk ' /executable.*dynamically/ { print $$1 }' > $(TMP_DIR)/mklibs-progs
        # find all loadable objects that are not regular libraries and add them to the list as well