PATCH: upgrades kismet to 2007-10-R1
authorFelix Fietkau <nbd@openwrt.org>
Tue, 4 Dec 2007 01:34:51 +0000 (01:34 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 4 Dec 2007 01:34:51 +0000 (01:34 +0000)
This patch updates kismet to 2007-10-R1.  I have been using
kismet_server compiled from this on r9512 for about a month on a
wgt634u with no problems.

Signed-off-by: Russell Senior <seniorr@aracnet.com>
SVN-Revision: 9653

net/kismet/Makefile
net/kismet/patches/100-200701r1b_iwfreq_24_kernel.diff [deleted file]
net/kismet/patches/100-fix-atan.patch [new file with mode: 0644]

index 756f02d77b7d46759b375832754db2057c1cd38a..048b3f72cf1b8221554796764292b034d1c681a2 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kismet
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kismet
-PKG_VERSION:=2007-01-R1a
+PKG_VERSION:=2007-10-R1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kismetwireless.net/code
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kismetwireless.net/code
-PKG_MD5SUM:=5921166366d3f695eeef26121c56a674
+PKG_MD5SUM:=2100c667e69db0cde35fa2d06c8516e2
 
 PKG_BUILD_DEPENDS:=libnotimpl libpcap libncurses uclibcxx
 
 
 PKG_BUILD_DEPENDS:=libnotimpl libpcap libncurses uclibcxx
 
@@ -69,7 +69,7 @@ endef
 
 define Package/kismet-server
 $(call Package/kismet/Default)
 
 define Package/kismet-server
 $(call Package/kismet/Default)
-  DEPENDS+= +libpcap
+  DEPENDS+= +libpcap +dbus
   TITLE+= server
 endef
 
   TITLE+= server
 endef
 
diff --git a/net/kismet/patches/100-200701r1b_iwfreq_24_kernel.diff b/net/kismet/patches/100-200701r1b_iwfreq_24_kernel.diff
deleted file mode 100644 (file)
index b4bf8d0..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-diff -ur kismet-2007-01-R1b/config.h.in temp/config.h.in
---- kismet-2007-01-R1b/config.h.in     2006-10-13 16:50:32.000000000 -0400
-+++ temp/config.h.in   2007-01-17 10:02:43.000000000 -0500
-@@ -60,6 +60,9 @@
- /* Libz compression lib */
- #undef HAVE_LIBZ
-+/* Linux wireless iwfreq.flag */
-+#undef HAVE_LINUX_IWFREQFLAG
-+
- /* Linux netlink socket capture present */
- #undef HAVE_LINUX_NETLINK
-diff -ur kismet-2007-01-R1b/configure temp/configure
---- kismet-2007-01-R1b/configure       2006-12-27 09:32:52.000000000 -0500
-+++ temp/configure     2007-01-17 10:02:43.000000000 -0500
-@@ -7795,6 +7795,92 @@
-               fi
-+              iwfreqflag=no
-+              { echo "$as_me:$LINENO: checking can we use iw_freq.flags" >&5
-+echo $ECHO_N "checking can we use iw_freq.flags... $ECHO_C" >&6; }
-+              cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h.  */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h.  */
-+
-+                      #include <stdio.h>
-+                      #include <sys/types.h>
-+                      #include <netinet/in.h>
-+                      #include <asm/types.h>
-+                      #include <linux/if.h>
-+                      #include <linux/wireless.h>
-+
-+int
-+main ()
-+{
-+
-+                      struct iwreq wrq;
-+                      wrq.u.freq.flags = IW_FREQ_FIXED;
-+
-+  ;
-+  return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (ac_try="$ac_link"
-+case "(($ac_try" in
-+  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-+  *) ac_try_echo=$ac_try;;
-+esac
-+eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-+  (eval "$ac_link") 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } &&
-+       { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
-+  { (case "(($ac_try" in
-+  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-+  *) ac_try_echo=$ac_try;;
-+esac
-+eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-+  (eval "$ac_try") 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; } &&
-+       { ac_try='test -s conftest$ac_exeext'
-+  { (case "(($ac_try" in
-+  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-+  *) ac_try_echo=$ac_try;;
-+esac
-+eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-+  (eval "$ac_try") 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; }; then
-+  iwfreqflag=yes
-+else
-+  echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+      iwfreqflag=no
-+fi
-+
-+rm -f core conftest.err conftest.$ac_objext \
-+      conftest$ac_exeext conftest.$ac_ext
-+
-+              if test "$iwfreqflag" = "no"; then
-+                      { echo "$as_me:$LINENO: result: no" >&5
-+echo "${ECHO_T}no" >&6; }
-+              else
-+                      { echo "$as_me:$LINENO: result: yes" >&5
-+echo "${ECHO_T}yes" >&6; }
-+
-+cat >>confdefs.h <<\_ACEOF
-+#define HAVE_LINUX_IWFREQFLAG 1
-+_ACEOF
-+
-+              fi
-+
-       fi
- fi
-diff -ur kismet-2007-01-R1b/configure.in temp/configure.in
---- kismet-2007-01-R1b/configure.in    2006-12-27 09:32:52.000000000 -0500
-+++ temp/configure.in  2007-01-17 10:02:43.000000000 -0500
-@@ -438,6 +438,27 @@
-                       AC_DEFINE(HAVE_LINUX_WIRELESS22, 1, [Linux wireless extentions v22 or better present])
-               fi
-+              iwfreqflag=no
-+              AC_MSG_CHECKING(can we use iw_freq.flags)
-+              AC_LINK_IFELSE([AC_LANG_PROGRAM([[
-+                      #include <stdio.h>
-+                      #include <sys/types.h>
-+                      #include <netinet/in.h>
-+                      #include <asm/types.h>
-+                      #include <linux/if.h>
-+                      #include <linux/wireless.h>
-+              ]], [[
-+                      struct iwreq wrq;
-+                      wrq.u.freq.flags = IW_FREQ_FIXED;
-+              ]])],[iwfreqflag=yes],[iwfreqflag=no])
-+
-+              if test "$iwfreqflag" = "no"; then
-+                      AC_MSG_RESULT(no)
-+              else
-+                      AC_MSG_RESULT(yes)
-+                      AC_DEFINE(HAVE_LINUX_IWFREQFLAG, 1, [Linux wireless iwfreq.flag])
-+              fi
-+
-       fi
- fi
-diff -ur kismet-2007-01-R1b/iwcontrol.cc temp/iwcontrol.cc
---- kismet-2007-01-R1b/iwcontrol.cc    2006-11-17 11:13:23.000000000 -0500
-+++ temp/iwcontrol.cc  2007-01-17 10:02:43.000000000 -0500
-@@ -519,7 +519,9 @@
-     memset(&wrq, 0, sizeof(struct iwreq));
-     strncpy(wrq.ifr_name, in_dev, IFNAMSIZ);
-+#ifdef HAVE_LINUX_IWFREQFLAG
-       wrq.u.freq.flags = IW_FREQ_FIXED;
-+#endif
-     IwFloat2Freq(in_ch, &wrq.u.freq);
-     // Try twice with a tiny delay, some cards (madwifi) need a second chance...
diff --git a/net/kismet/patches/100-fix-atan.patch b/net/kismet/patches/100-fix-atan.patch
new file mode 100644 (file)
index 0000000..30a598f
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ru kismet-2007-10-R1/gpsd.cc kismet-2007-10-R1-fixed/gpsd.cc
+--- kismet-2007-10-R1/gpsd.cc  2007-09-15 09:14:00.000000000 -0700
++++ kismet-2007-10-R1-fixed/gpsd.cc    2007-11-06 01:46:12.000000000 -0800
+@@ -323,7 +323,7 @@
+               if (ty == 0) {
+                       dir = 0.0;
+               } else {
+-                      dir = atan(tx / ty);
++                      dir = atan2(tx,ty);
+               }
+               if (!finite(dir))