More libtool madness: Every package which was using c++ and libtool fixup
authorLars-Peter Clausen <lars@metafoo.de>
Thu, 4 Jun 2009 00:20:01 +0000 (00:20 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Thu, 4 Jun 2009 00:20:01 +0000 (00:20 +0000)
was linked against libstd++ even though if it should have been linked
against uclibc++. This is fixed by providing a special version of libtool
fixup for packages which should use uclibc++. Not pretty but functional.
Packages linking against uclibc++ should use PKG_FIXUP:=libtool-ucxx instead of
PKG_FIXUP:=libtool

Somebody should probably check all packages using c++ with a dependency on stdlibc++
if uclibc++ can be used instead now.

SVN-Revision: 16317

include/autotools.mk
package/libtool/Makefile

index 558e247fd80d6f03b16dc049525d7f16893f42b1..5d51d7a328b8d9488c40a5f62b07554d9d564fa1 100644 (file)
@@ -1,20 +1,23 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define replace
-       if [ -f "$(PKG_BUILD_DIR)/$(3)$(1)" -a -e "$(2)/$(1)" ]; then \
+       if [ -f "$(PKG_BUILD_DIR)/$(3)$(1)" -a -e "$(2)/$(if $(4),$(4),$(1))" ]; then \
                rm -f $(PKG_BUILD_DIR)/$(3)$(1); \
-               ln -s $(2)/$(1) $(PKG_BUILD_DIR)/$(3); \
+               ln -s $(2)/$(if $(4),$(4),$(1)) $(PKG_BUILD_DIR)/$(3)$(1); \
        fi
        
 endef
 
 # replace copies of ltmain.sh with the build system's version
-update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)$(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(CONFIGURE_PATH)/)
+update_libtool_common=$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)$(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(CONFIGURE_PATH)/)
+update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call update_libtool_common)
+update_libtool_ucxx=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/,libtool-ucxx)$(call update_libtool_common)
+
 
 # prevent libtool from linking against host development libraries
 define libtool_fixup_libdir
@@ -38,3 +41,11 @@ ifneq ($(filter libtool,$(PKG_FIXUP)),)
   Hooks/Configure/Post += update_libtool
   Hooks/InstallDev/Post += libtool_fixup_libdir
 endif
+
+ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
+  PKG_BUILD_DEPENDS += libtool
+  Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
+  Hooks/Configure/Post += update_libtool_ucxx
+  Hooks/InstallDev/Post += libtool_fixup_libdir
+endif
+
index f179cd7c2a45487026d127174bf46c782454a5ed..8d50a7adacb0c136c3a543340a9170e8fbc0d1d5 100644 (file)
@@ -45,6 +45,8 @@ define Build/InstallDev
        mv $(2)/lib/* $(1)/usr/lib/
        mv $(2)/include/* $(1)/usr/include/
        $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(2)/bin/libtool
+       $(CP) $(2)/bin/libtool $(2)/bin/libtool-ucxx
+       $(SED) 's,-lstdc++,-luClibc++,g' $(2)/bin/libtool-ucxx
 endef
 
 define Package/libltdl/install