prosody: moved to github
authorSteven Barth <cyrus@openwrt.org>
Mon, 21 Jul 2014 14:37:51 +0000 (14:37 +0000)
committerSteven Barth <cyrus@openwrt.org>
Mon, 21 Jul 2014 14:37:51 +0000 (14:37 +0000)
SVN-Revision: 41782

net/prosody/Makefile [deleted file]
net/prosody/files/prosody.init [deleted file]
net/prosody/patches/001-conf.patch [deleted file]

diff --git a/net/prosody/Makefile b/net/prosody/Makefile
deleted file mode 100644 (file)
index 025a3e4..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-#
-# Copyright (C) 2009-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=prosody
-PKG_VERSION:=0.6.2
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://prosody.im/downloads/source
-PKG_MD5SUM:=5da59bc906419ad3b4faa21516a6ca18
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/prosody
-  SECTION:=net
-  CATEGORY:=Network
-  SUBMENU:=Instant Messaging
-  DEPENDS:=+luafilesystem +libidn +luaexpat +luasec
-  TITLE:=XMPP server
-  URL:=http://prosody.im/
-endef
-
-define Package/prosody/description
-  Prosody is an exciting new server for Jabber/XMPP
-  written in Lua. It aims to be easy to use, and light
-  on resources
-endef
-
-define Package/prosody/conffiles
-/etc/prosody/prosody.cfg.lua
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Configure
-       # this is *NOT* GNU autoconf stuff
-       (cd $(PKG_BUILD_DIR); ./configure \
-               --prefix=/usr \
-               --with-lua="$(STAGING_DIR)/host/bin" \
-               --with-lua-include="$(STAGING_DIR)/usr/include" \
-               --with-lua-lib="$(STAGING_DIR)/usr/lib" \
-               --cflags="$(TARGET_CFLAGS)" \
-               --datadir="/etc/prosody/data" \
-       )
-endef
-
-MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -std=gnu99" \
-       LDFLAGS="$(TARGET_LDFLAGS)" \
-       PREFIX="/usr" \
-
-define Package/prosody/install
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/prosody.init $(1)/etc/init.d/prosody
-       $(INSTALL_DIR) $(1)/etc/prosody
-       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/prosody/prosody.cfg.lua $(1)/etc/prosody/
-       $(INSTALL_DIR) $(1)/etc/prosody/certs
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/prosody/certs/localhost.{cert,key} $(1)/etc/prosody/certs/
-       $(INSTALL_DIR) $(1)/etc/prosody/data
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/prosody{,ctl} $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/usr/lib/prosody
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/prosody/prosody.version $(1)/usr/lib/prosody/
-       $(INSTALL_DIR) $(1)/usr/lib/prosody/core
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/core/*.lua $(1)/usr/lib/prosody/core/
-       $(INSTALL_DIR) $(1)/usr/lib/prosody/fallbacks
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/fallbacks/*.lua $(1)/usr/lib/prosody/fallbacks/
-       $(INSTALL_DIR) $(1)/usr/lib/prosody/modules
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/modules/*.lua $(1)/usr/lib/prosody/modules/
-       $(INSTALL_DIR) $(1)/usr/lib/prosody/modules/muc
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/modules/muc/*.lua $(1)/usr/lib/prosody/modules/muc/
-       $(INSTALL_DIR) $(1)/usr/lib/prosody/net
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/net/*.lua $(1)/usr/lib/prosody/net/
-       $(INSTALL_DIR) $(1)/usr/lib/prosody/util
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.lua $(1)/usr/lib/prosody/util/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.so $(1)/usr/lib/prosody/util/
-endef
-
-$(eval $(call BuildPackage,prosody))
diff --git a/net/prosody/files/prosody.init b/net/prosody/files/prosody.init
deleted file mode 100644 (file)
index af1614d..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2010-2011 OpenWrt.org
-
-START=99
-
-EXTRA_COMMANDS="status"
-EXTRA_HELP="   status  Print the status of the service"
-
-BIN=/usr/bin/prosodyctl
-LOG_D=/var/log/prosody
-RUN_D=/var/run/prosody
-PID_F=$RUN_D/prosody.pid
-RUN_USER=prosody
-RUN_GROUP=prosody
-
-start() {
-       user_exists prosody 54 || user_add prosody 54
-       group_exists prosody 54 || group_add prosody 54
-       [ -d /var/run/prosody ] || {
-               mkdir -m 0755 -p /var/run/prosody
-               chown prosody:prosody /var/run/prosody
-       }
-       [ -d /var/log/prosody ] || {
-               mkdir -m 0755 -p /var/log/prosody
-               chown prosody:prosody /var/log/prosody
-       }
-
-       $BIN start
-}
-
-stop() {
-       $BIN stop
-}
-
-reload() {
-       [ -f $PID_F ] && kill -HUP $(cat $PID_F)
-}
-
-status() {
-       $BIN status
-}
diff --git a/net/prosody/patches/001-conf.patch b/net/prosody/patches/001-conf.patch
deleted file mode 100644 (file)
index 4b23f9a..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/prosody.cfg.lua.dist
-+++ b/prosody.cfg.lua.dist
-@@ -47,7 +47,7 @@ modules_enabled = {
-               "register"; -- Allow users to register on this server using a client and change passwords
-       
-       -- Other specific functionality
--              --"posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
-+              "posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
-               --"console"; -- Opens admin telnet interface on localhost port 5582
-               --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
-               --"httpserver"; -- Serve static files from a directory over HTTP
-@@ -65,6 +65,9 @@ modules_disabled = {
- -- Disable account creation by default, for security
- -- For more information see http://prosody.im/doc/creating_accounts
- allow_registration = false;
-+
-+-- File to write pid in
-+pidfile = "/var/run/prosody/prosody.pid";
-       
- -- These are the SSL/TLS-related settings. If you don't want
- -- to use SSL/TLS, you may comment or remove this
-@@ -73,6 +76,15 @@ ssl = {
-       certificate = "certs/localhost.cert";
- }
-+-- Errors to syslog
-+-- All to /var/log/prosody/
-+log = {
-+      { levels = { "error" }; to = "syslog";  };
-+      { levels = { "error" }; to = "file"; filename = "/var/log/prosody/prosody.err";  };
-+      -- Change "info" to "debug" for more verbose logging
-+      { levels = { min = "info" }; to = "file"; filename = "/var/log/prosody/prosody.log";  };
-+}
-+
- ----------- Virtual hosts -----------
- -- You need to add a VirtualHost entry for each domain you wish Prosody to serve.
- -- Settings under each VirtualHost entry apply *only* to that host.