[package] stage krb5 headers and libs
authorFlorian Fainelli <florian@openwrt.org>
Sun, 24 Oct 2010 11:13:18 +0000 (11:13 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 24 Oct 2010 11:13:18 +0000 (11:13 +0000)
This is needed for other packages to link against krb5.

Signed-off-by: Daniel Golle <daniel.golle@gmail.com>
SVN-Revision: 23613

net/krb5/Makefile

index ac1856695bb7ef0cc0aad5cd821359101da03960..90ae205d8375a9772ed8e46528ef0d0b72b293bd 100644 (file)
@@ -72,6 +72,14 @@ CONFIGURE_ARGS += \
        --without-tcl \
        --disable-ipv6
 
        --without-tcl \
        --disable-ipv6
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include \
+               $(PKG_INSTALL_DIR)/usr/lib \
+               $(1)/usr/
+endef
+
 define Package/krb5-libs/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/lib/krb5
 define Package/krb5-libs/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/lib/krb5