kernel: update kernel 3.18 to version 3.18.29
authorRafał Miłecki <zajec5@gmail.com>
Wed, 30 Mar 2016 16:41:26 +0000 (16:41 +0000)
committerRafał Miłecki <zajec5@gmail.com>
Wed, 30 Mar 2016 16:41:26 +0000 (16:41 +0000)
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
SVN-Revision: 49096

include/kernel-version.mk
target/linux/generic/patches-3.18/082-ipv6-ip6_fragment-fix-headroom-tests-and-skb-leak.patch
target/linux/generic/patches-3.18/192-USB-qcserial-Add-support-for-Quectel-EC20-Mini-PCIe-.patch
target/linux/generic/patches-3.18/532-jffs2_eofdetect.patch
target/linux/generic/patches-3.18/667-ipv6-Fixed-source-specific-default-route-handling.patch

index 6080ed6aca0a2d9a196f1c83016c2147e5ca4615..bdaa7f139aec7419515fd07f5b1ab1e2da90faf0 100644 (file)
@@ -2,12 +2,12 @@
 
 LINUX_RELEASE?=1
 
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .27
+LINUX_VERSION-3.18 = .29
 LINUX_VERSION-4.1 = .20
 LINUX_VERSION-4.3 = .4
 LINUX_VERSION-4.4 = .6
 
 LINUX_VERSION-4.1 = .20
 LINUX_VERSION-4.3 = .4
 LINUX_VERSION-4.4 = .6
 
-LINUX_KERNEL_MD5SUM-3.18.27 = 015a01bf84e7c6bc9952551b4da45044
+LINUX_KERNEL_MD5SUM-3.18.29 = b25737a0bc98e80d12200de93f239c28
 LINUX_KERNEL_MD5SUM-4.1.20 = 075c38a3a23ca5bc80437b13606df00a
 LINUX_KERNEL_MD5SUM-4.3.4 = 5275d02132107c28b85f986bad576d91
 LINUX_KERNEL_MD5SUM-4.4.6 = efc822dad2149e40cc908718a4fea1d3
 LINUX_KERNEL_MD5SUM-4.1.20 = 075c38a3a23ca5bc80437b13606df00a
 LINUX_KERNEL_MD5SUM-4.3.4 = 5275d02132107c28b85f986bad576d91
 LINUX_KERNEL_MD5SUM-4.4.6 = efc822dad2149e40cc908718a4fea1d3
index 7c833c41021b116fc238bae905dbe38f347d9ff5..d3da41e91805393b51785d3f32312a3266d5338e 100644 (file)
@@ -44,7 +44,7 @@ Closes 20532
 
 --- a/net/ipv6/ip6_output.c
 +++ b/net/ipv6/ip6_output.c
 
 --- a/net/ipv6/ip6_output.c
 +++ b/net/ipv6/ip6_output.c
-@@ -594,20 +594,22 @@ int ip6_fragment(struct sk_buff *skb, in
+@@ -597,20 +597,22 @@ int ip6_fragment(struct sk_buff *skb, in
        }
        mtu -= hlen + sizeof(struct frag_hdr);
  
        }
        mtu -= hlen + sizeof(struct frag_hdr);
  
@@ -69,7 +69,7 @@ Closes 20532
                                goto slow_path_clean;
  
                        /* Partially cloned skb? */
                                goto slow_path_clean;
  
                        /* Partially cloned skb? */
-@@ -624,8 +626,6 @@ int ip6_fragment(struct sk_buff *skb, in
+@@ -627,8 +629,6 @@ int ip6_fragment(struct sk_buff *skb, in
  
                err = 0;
                offset = 0;
  
                err = 0;
                offset = 0;
@@ -78,7 +78,7 @@ Closes 20532
                /* BUILD HEADER */
  
                *prevhdr = NEXTHDR_FRAGMENT;
                /* BUILD HEADER */
  
                *prevhdr = NEXTHDR_FRAGMENT;
-@@ -633,8 +633,11 @@ int ip6_fragment(struct sk_buff *skb, in
+@@ -636,8 +636,11 @@ int ip6_fragment(struct sk_buff *skb, in
                if (!tmp_hdr) {
                        IP6_INC_STATS(net, ip6_dst_idev(skb_dst(skb)),
                                      IPSTATS_MIB_FRAGFAILS);
                if (!tmp_hdr) {
                        IP6_INC_STATS(net, ip6_dst_idev(skb_dst(skb)),
                                      IPSTATS_MIB_FRAGFAILS);
@@ -91,7 +91,7 @@ Closes 20532
  
                __skb_pull(skb, hlen);
                fh = (struct frag_hdr *)__skb_push(skb, sizeof(struct frag_hdr));
  
                __skb_pull(skb, hlen);
                fh = (struct frag_hdr *)__skb_push(skb, sizeof(struct frag_hdr));
-@@ -732,7 +735,6 @@ slow_path:
+@@ -735,7 +738,6 @@ slow_path:
         */
  
        *prevhdr = NEXTHDR_FRAGMENT;
         */
  
        *prevhdr = NEXTHDR_FRAGMENT;
index cf5b3fe34ca3e2d84d2fabadd1279ea8afd241aa..7c49a6f11114b646c2ca707faa92c5f70d46c108 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
  /* standard device layouts supported by this driver */
  enum qcserial_layouts {
        QCSERIAL_G2K = 0,       /* Gobi 2000 */
  /* standard device layouts supported by this driver */
  enum qcserial_layouts {
        QCSERIAL_G2K = 0,       /* Gobi 2000 */
-@@ -166,6 +168,38 @@ static const struct usb_device_id id_tab
+@@ -171,6 +173,38 @@ static const struct usb_device_id id_tab
  };
  MODULE_DEVICE_TABLE(usb, id_table);
  
  };
  MODULE_DEVICE_TABLE(usb, id_table);
  
@@ -100,7 +100,7 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
  static int qcprobe(struct usb_serial *serial, const struct usb_device_id *id)
  {
        struct usb_host_interface *intf = serial->interface->cur_altsetting;
  static int qcprobe(struct usb_serial *serial, const struct usb_device_id *id)
  {
        struct usb_host_interface *intf = serial->interface->cur_altsetting;
-@@ -234,6 +268,11 @@ static int qcprobe(struct usb_serial *se
+@@ -239,6 +273,11 @@ static int qcprobe(struct usb_serial *se
                        altsetting = -1;
                break;
        case QCSERIAL_G2K:
                        altsetting = -1;
                break;
        case QCSERIAL_G2K:
index 9cbe183138889dc558857d2d565562acfcbd7afa..8ce53d8bed54ce225da77dc65e150d89dcf93301 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/jffs2/build.c
 +++ b/fs/jffs2/build.c
 --- a/fs/jffs2/build.c
 +++ b/fs/jffs2/build.c
-@@ -114,6 +114,16 @@ static int jffs2_build_filesystem(struct
+@@ -116,6 +116,16 @@ static int jffs2_build_filesystem(struct
        dbg_fsbuild("scanned flash completely\n");
        jffs2_dbg_dump_block_lists_nolock(c);
  
        dbg_fsbuild("scanned flash completely\n");
        jffs2_dbg_dump_block_lists_nolock(c);
  
index d02e08501c8afdde92180fa667080450e4e31dea..0c951069c24e8295b939003149029f0a2a14479e 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/net/ipv6/ip6_output.c
 +++ b/net/ipv6/ip6_output.c
 
 --- a/net/ipv6/ip6_output.c
 +++ b/net/ipv6/ip6_output.c
-@@ -900,21 +900,45 @@ static int ip6_dst_lookup_tail(struct so
+@@ -903,21 +903,45 @@ static int ip6_dst_lookup_tail(struct so
  #endif
        int err;
  
  #endif
        int err;