[xburst] The lcm driver currently does not use any of the backlight api, so
authorLars-Peter Clausen <lars@metafoo.de>
Tue, 16 Mar 2010 23:15:18 +0000 (23:15 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Tue, 16 Mar 2010 23:15:18 +0000 (23:15 +0000)
remove CONFIG_BACKLIGHT_CLASS_DEVICE as a dependecy and from the config. Fixes #6871

SVN-Revision: 20248

target/linux/xburst/patches-2.6.32/103-lcm.patch
target/linux/xburst/qi_lb60/config-2.6.32

index b1f71ba..40c3671 100644 (file)
@@ -16,7 +16,7 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/103-lc
  
 +config LCD_GPM940B0
 +      tristate "Giantplus GPM940B0 LCD and backlight driver"
-+      depends on LCD_CLASS_DEVICE && BACKLIGHT_CLASS_DEVICE && SPI
++      depends on LCD_CLASS_DEVICE && SPI
 +      default n
 +      help
 +      LCD and backlight driver for the Giantplus GPM940B0 LCD module.
index fdd2f01..427b92b 100644 (file)
@@ -1,4 +1,3 @@
-ONFIG_BACKLIGHT_CLASS_DEVICE=y
 CONFIG_BACKLIGHT_LCD_SUPPORT=y
 CONFIG_BATTERY_JZ4740=y
 CONFIG_CHARGER_GPIO=y