projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
|
inline
| side by side (parent:
6e785d4
)
Fix pmacct and friends compilation
author
Florian Fainelli
<florian@openwrt.org>
Thu, 11 Jan 2007 11:38:27 +0000
(11:38 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Thu, 11 Jan 2007 11:38:27 +0000
(11:38 +0000)
SVN-Revision: 6076
net/pmacct/Makefile
patch
|
blob
|
history
diff --git
a/net/pmacct/Makefile
b/net/pmacct/Makefile
index 7b5398dfcfcbce4c6a6c31772e202d5bb1952bc0..a619bafa5a84d5d942959aef39775cf1e1c65141 100644
(file)
--- a/
net/pmacct/Makefile
+++ b/
net/pmacct/Makefile
@@
-114,9
+114,9
@@
$(PKG_BUILD_DIR)/nfacctd-$(1) $(PKG_BUILD_DIR)/pmacctd-$(1): $(PKG_BUILD_DIR)/.c
$(call Build/Configure/Default, \
--with-pcap-includes="$(STAGING_DIR)/usr/include" \
--with-pcap-libs="$(STAGING_DIR)/usr/lib" \
$(call Build/Configure/Default, \
--with-pcap-includes="$(STAGING_DIR)/usr/include" \
--with-pcap-libs="$(STAGING_DIR)/usr/lib" \
-
$(2)
\
- ,
\
- LIBS="-lz" \
+
"$(2)"
\
+ ,\
+ LIBS
+
="-lz" \
);
$(MAKE) -C $(PKG_BUILD_DIR) \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
);
$(MAKE) -C $(PKG_BUILD_DIR) \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@
-160,8
+160,6
@@
ifneq ($(CONFIG_PACKAGE_nfacctd-mysql)$(CONFIG_PACKAGE_pmacctd-mysql),)
--enable-mysql \
--with-mysql-includes="$(STAGING_DIR)/usr/include" \
--with-mysql-libs="$(STAGING_DIR)/usr/lib/mysql" \
--enable-mysql \
--with-mysql-includes="$(STAGING_DIR)/usr/include" \
--with-mysql-libs="$(STAGING_DIR)/usr/lib/mysql" \
- , \
- LIBS='-lz' \
))
$(eval $(call Install/Template,nfacctd-mysql,nfacctd-mysql,nfacctd))
$(eval $(call Install/Template,pmacctd-mysql,pmacctd-mysql,pmacctd))
))
$(eval $(call Install/Template,nfacctd-mysql,nfacctd-mysql,nfacctd))
$(eval $(call Install/Template,pmacctd-mysql,pmacctd-mysql,pmacctd))