[PATCH] Add support for CM109 USB VoIP phone
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Apr 2009 15:27:25 +0000 (15:27 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Apr 2009 15:27:25 +0000 (15:27 +0000)
this patch adds support for USB VoIP-phones using the CM109 chipset.
the cm109.ko module was added to linux kernel 2.6.28
it was tested with SVN revision 15247 on a Asus WL-500G Premium.

Signed-off-by: Alfred E. Heggestad <aeh@db.org>
SVN-Revision: 15258

package/kernel/modules/usb.mk

index 813e3a98c14904e91b7afee375295de052af3a61..82250861a85e9596473e8dfffce589dc3184e58a 100644 (file)
@@ -665,6 +665,22 @@ endef
 
 $(eval $(call KernelPackage,usb-yealink))
 
+
+define KernelPackage/usb-cm109
+  $(call usbdep,@LINUX_2_6 +kmod-input-core +kmod-input-evdev)
+  TITLE:=Support for CM109 device
+  KCONFIG:=CONFIG_USB_CM109 CONFIG_INPUT_CM109 CONFIG_INPUT=m CONFIG_INPUT_MISC=y
+  FILES:=$(LINUX_DIR)/drivers/$(USBINPUT_DIR)/cm109.ko
+  AUTOLOAD:=$(call AutoLoad,70,cm109)
+endef
+
+define KernelPackage/usb-cm109/description
+ Kernel support for CM109 VOIP phone
+endef
+
+$(eval $(call KernelPackage,usb-cm109))
+
+
 define KernelPackage/usb-test
   $(call usbdep,@LINUX_2_6 @DEVEL)
   TITLE:=USB Testing Driver