[package] uhttpd:
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 3 Apr 2010 13:09:10 +0000 (13:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 3 Apr 2010 13:09:10 +0000 (13:09 +0000)
- cope with options instead of lists in uci config
- fix compilation without tls (#7050)
- bump to rev 7

SVN-Revision: 20668

package/uhttpd/Makefile
package/uhttpd/files/uhttpd.init
package/uhttpd/src/uhttpd.c

index 180e2284c3f1a904e9c523078e5aa39aa50ca325..6b4db3e15f437001fad573a5078c66a2871e6945 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index ba7dd49fbd14ba08d9685995d26bea6044d272ec..4b747a0da1d47bdb0c7315d53ec6b097c85142cd 100755 (executable)
@@ -6,14 +6,6 @@ UHTTPD_BIN="/usr/sbin/uhttpd"
 PX5G_BIN="/usr/sbin/px5g"
 
 
 PX5G_BIN="/usr/sbin/px5g"
 
 
-append_listen_http() {
-       append UHTTPD_ARGS "-p $1"
-}
-
-append_listen_https() {
-       append UHTTPD_ARGS "-s $1"
-}
-
 append_arg() {
        local cfg="$1"
        local var="$2"
 append_arg() {
        local cfg="$1"
        local var="$2"
@@ -57,7 +49,7 @@ start_instance()
 
        local cfg="$1"
        local realm="$(uci get system.@system[0].hostname 2>/dev/null)"
 
        local cfg="$1"
        local realm="$(uci get system.@system[0].hostname 2>/dev/null)"
-       local ssl
+       local listen http https
 
        append_arg "$cfg" home "-h"
        append_arg "$cfg" realm "-r" "${realm:-OpenWrt}"
 
        append_arg "$cfg" home "-h"
        append_arg "$cfg" realm "-r" "${realm:-OpenWrt}"
@@ -67,14 +59,16 @@ start_instance()
        append_arg "$cfg" lua_handler "-L"
        append_arg "$cfg" script_timeout "-t"
 
        append_arg "$cfg" lua_handler "-L"
        append_arg "$cfg" script_timeout "-t"
 
-       config_list_foreach "$cfg" listen_http \
-               append_listen_http
+       config_get http "$cfg" listen_http
+       for listen in $http; do
+               append UHTTPD_ARGS "-p $listen"
+       done
 
 
-       config_get ssl "$cfg" listen_https
+       config_get https "$cfg" listen_https
        config_get UHTTPD_KEY  "$cfg" key  /etc/uhttpd.key
        config_get UHTTPD_CERT "$cfg" cert /etc/uhttpd.crt
 
        config_get UHTTPD_KEY  "$cfg" key  /etc/uhttpd.key
        config_get UHTTPD_CERT "$cfg" cert /etc/uhttpd.crt
 
-       [ -n "$ssl" ] && {
+       [ -n "$https" ] && {
                [ -f "$UHTTPD_CERT" -a -f "$UHTTPD_KEY" ] || {
                        config_foreach generate_keys cert
                }
                [ -f "$UHTTPD_CERT" -a -f "$UHTTPD_KEY" ] || {
                        config_foreach generate_keys cert
                }
@@ -83,8 +77,9 @@ start_instance()
                        append_arg "$cfg" cert "-C"
                        append_arg "$cfg" key  "-K"
 
                        append_arg "$cfg" cert "-C"
                        append_arg "$cfg" key  "-K"
 
-                       config_list_foreach "$cfg" listen_https \
-                               append_listen_https
+                       for listen in $https; do
+                               append UHTTPD_ARGS "-s $listen"
+                       done
                }
        }
 
                }
        }
 
index c6a8b6c272caadbe01dfc282846fa18a38de7a89..da3779413ecd6f92ca8f768962cd3bed8f0eba8a 100644 (file)
@@ -524,6 +524,7 @@ int main (int argc, char **argv)
                                        port = optarg;
                                }
 
                                        port = optarg;
                                }
 
+#ifdef HAVE_TLS
                                if( opt == 's' )
                                {
                                        if( !conf.tls )
                                if( opt == 's' )
                                {
                                        if( !conf.tls )
@@ -537,6 +538,7 @@ int main (int argc, char **argv)
 
                                        tls = 1;
                                }
 
                                        tls = 1;
                                }
+#endif
 
                                /* bind sockets */
                                bound += uh_socket_bind(
 
                                /* bind sockets */
                                bound += uh_socket_bind(