[packages] collectd: remove further instances of -Werror to fix compilation with...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 14 Feb 2012 18:09:22 +0000 (18:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 14 Feb 2012 18:09:22 +0000 (18:09 +0000)
SVN-Revision: 30533

utils/collectd/Makefile
utils/collectd/patches/003-remove-werror.patch

index 1256dd49d9e5f97788d67c3644f48d1d45686061..80c0dd53156eaa602fa6162d6b9420c8ebb77d0b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=collectd
 PKG_VERSION:=4.10.2
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://collectd.org/files/
index 89fce67f384d48a0d38c6ebef99edddee826520f..5a4fb53e250ac0a3da2c12efa5a795d0e66429c2 100644 (file)
  AM_CPPFLAGS = -DPREFIX='"${prefix}"' \
        -DCONFIGFILE='"${sysconfdir}/${PACKAGE_NAME}.conf"' \
        -DLOCALSTATEDIR='"${localstatedir}"' \
+--- a/src/libcollectdclient/Makefile.am
++++ b/src/libcollectdclient/Makefile.am
+@@ -1,7 +1,7 @@
+ AUTOMAKE_OPTIONS = foreign no-dependencies
+ if COMPILER_IS_GCC
+-AM_CFLAGS = -Wall -Werror
++AM_CFLAGS = -Wall
+ endif
+ pkginclude_HEADERS = client.h lcc_features.h
+--- a/src/libcollectdclient/Makefile.in
++++ b/src/libcollectdclient/Makefile.in
+@@ -329,7 +329,7 @@ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AUTOMAKE_OPTIONS = foreign no-dependencies
+-@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall -Werror
++@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall
+ pkginclude_HEADERS = client.h lcc_features.h
+ lib_LTLIBRARIES = libcollectdclient.la
+ nodist_pkgconfig_DATA = libcollectdclient.pc
+--- a/src/owniptc/Makefile.am
++++ b/src/owniptc/Makefile.am
+@@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS = foreign no-dependenci
+ EXTRA_DIST = libiptc.c README.collectd
+ if COMPILER_IS_GCC
+-AM_CFLAGS = -Wall -Werror
++AM_CFLAGS = -Wall
+ endif
+ noinst_LTLIBRARIES = libiptc.la
+--- a/src/owniptc/Makefile.in
++++ b/src/owniptc/Makefile.in
+@@ -298,7 +298,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AUTOMAKE_OPTIONS = foreign no-dependencies
+ EXTRA_DIST = libiptc.c README.collectd
+-@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall -Werror
++@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall
+ noinst_LTLIBRARIES = libiptc.la
+ libiptc_la_SOURCES = libip4tc.c libip6tc.c \
+               ipt_kernel_headers.h libip6tc.h libiptc.h linux_list.h \