[packages] vsftpd: fix compilation if libcap has been built in the same tree (#10937)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 14 Mar 2012 18:42:09 +0000 (18:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 14 Mar 2012 18:42:09 +0000 (18:42 +0000)
SVN-Revision: 30941

net/vsftpd/Makefile
net/vsftpd/patches/003-chroot.patch
net/vsftpd/patches/004-disable-capabilities.patch [new file with mode: 0644]

index 32cae30a4adcce93a41fc336c163f3f4ed3d55b7..710ba96d696a5b4b1ee680b48719a0e8c47045e7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
 PKG_VERSION:=2.3.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://security.appspot.com/downloads/
index bf7318e4f76e5260876c2486ab604d36cbeb2613..6f7c34a66cba0fb870b76c1b2e0105a4f1134f20 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tunables.c
 +++ b/tunables.c
-@@ -244,7 +244,7 @@ tunables_load_defaults()
+@@ -250,7 +250,7 @@ tunables_load_defaults()
    /* -rw------- */
    tunable_chown_upload_mode = 0600;
  
diff --git a/net/vsftpd/patches/004-disable-capabilities.patch b/net/vsftpd/patches/004-disable-capabilities.patch
new file mode 100644 (file)
index 0000000..7aa6330
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/sysdeputil.c
++++ b/sysdeputil.c
+@@ -165,6 +165,9 @@
+ #endif
+ /* END config */
++#undef VSF_SYSDEP_HAVE_CAPABILITIES
++#undef VSF_SYSDEP_HAVE_LIBCAP
++
+ /* PAM support - we include our own dummy version if the system lacks this */
+ #include <security/pam_appl.h>