Add unzip from #1313
authorFlorian Fainelli <florian@openwrt.org>
Mon, 14 May 2007 21:51:46 +0000 (21:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 14 May 2007 21:51:46 +0000 (21:51 +0000)
SVN-Revision: 7242

utils/unzip/Makefile [new file with mode: 0644]

diff --git a/utils/unzip/Makefile b/utils/unzip/Makefile
new file mode 100644 (file)
index 0000000..43c4cde
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $ 
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=unzip
+PKG_VERSION:=5.52
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)552.zip
+PKG_SOURCE_URL:=@SF/infozip
+PKG_MD5SUM:=3d55b4e7375c3d0b81feca52dc0e4d48
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)/ $(DL_DIR)/$(PKG_SOURCE)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/unzip
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=
+  TITLE:=De-archiver for .zip files
+  DESCRIPTION:=\
+       InfoZIP's unzip program. With the exception of multi-volume archives \\\
+       (ie, .ZIP files that are split across several disks using PKZIP's /& option), \\\
+       this can handle any file produced either by PKZIP, or the corresponding \\\
+       InfoZIP zip program.
+  URL:=http://infozip.sourceforge.net/Zip.html
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile generic \
+               $(TARGET_CONFIGURE_OPTS) \
+               prefix="$(PKG_INSTALL_DIR)/usr" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CF="$(TARGET_CFLAGS) -O -I$(STAGING_DIR)/usr/include -I. -DUNIX" \
+               LD="$(TARGET_CC) -L$(STAGING_DIR)/usr/lib" \
+               install
+endef
+
+define Package/unzip/install   
+       $(INSTALL_DIR) $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,unzip))