Upgrade jamvm to 1.5.0, also fixes its compilation issues (#2935)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 3 Jan 2008 23:08:58 +0000 (23:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 3 Jan 2008 23:08:58 +0000 (23:08 +0000)
SVN-Revision: 10100

lang/jamvm/Makefile
lang/jamvm/patches/100-jamvm-mips.patch [deleted file]
lang/jamvm/patches/200-pthread_hacks.patch [deleted file]

index 3d544dc696839875728bdd87af5e685b1933436f..f1efa4b6a1f0298a66e454f94b00c8be4d07a024 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=jamvm
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=jamvm
-PKG_VERSION:=1.4.4
+PKG_VERSION:=1.5.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/jamvm
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/jamvm
-PKG_MD5SUM:=1b7bc9928c534412e062685a4191651d
+PKG_MD5SUM:=a965452442cdbfc94caba57d0dd25a8f
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -41,7 +41,9 @@ CONFIGURE_ARGS+= \
        --disable-int-threading \
 
 define Build/Compile   
        --disable-int-threading \
 
 define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CPPFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               all
 endef
 
 ifneq ($(ARCH),mips)
 endef
 
 ifneq ($(ARCH),mips)
diff --git a/lang/jamvm/patches/100-jamvm-mips.patch b/lang/jamvm/patches/100-jamvm-mips.patch
deleted file mode 100644 (file)
index f098416..0000000
+++ /dev/null
@@ -1,633 +0,0 @@
-diff -ruN jamvm-1.4.4-old/configure jamvm-1.4.4-new/configure
---- jamvm-1.4.4-old/configure  2006-12-18 15:31:28.000000000 +0100
-+++ jamvm-1.4.4-new/configure  2006-12-18 15:31:59.000000000 +0100
-@@ -2035,6 +2035,7 @@
- arm*-*-linux*) host_cpu=arm host_os=linux ;;
- arm*-*-openbsd*) host_cpu=arm host_os=bsd libdl_needed=no ;;
- arm*-*-freebsd*) host_cpu=arm host_os=bsd libdl_needed=no ;;
-+mips*-linux*) host_cpu=mips host_os=linux ;;
- powerpc*-*-linux*) host_cpu=powerpc host_os=linux ;;
- powerpc*-*-openbsd*) host_cpu=powerpc host_os=bsd libdl_needed=no ;;
- powerpc*-*-freebsd*) host_cpu=powerpc host_os=bsd libdl_needed=no ;;
-@@ -22949,7 +22950,7 @@
-           ac_config_links="$ac_config_links src/arch.h:src/arch/$arch.h"
--                                                                                                                                                                                                                                                                                        ac_config_files="$ac_config_files Makefile src/Makefile src/arch/Makefile src/os/Makefile src/os/linux/Makefile src/os/darwin/Makefile src/os/bsd/Makefile src/os/linux/powerpc/Makefile src/os/linux/arm/Makefile src/os/linux/i386/Makefile src/os/linux/x86_64/Makefile src/os/linux/parisc/Makefile src/os/darwin/i386/Makefile src/os/darwin/powerpc/Makefile src/os/bsd/powerpc/Makefile src/os/bsd/arm/Makefile src/os/bsd/i386/Makefile src/os/bsd/x86_64/Makefile lib/Makefile lib/java/Makefile lib/java/lang/Makefile lib/jamvm/Makefile lib/jamvm/java/Makefile lib/jamvm/java/lang/Makefile lib/java/lang/reflect/Makefile lib/java/security/Makefile lib/gnu/Makefile lib/gnu/classpath/Makefile"
-+                                                                                                                                                                                                                                                                                        ac_config_files="$ac_config_files Makefile src/Makefile src/arch/Makefile src/os/Makefile src/os/linux/Makefile src/os/darwin/Makefile src/os/bsd/Makefile src/os/linux/powerpc/Makefile src/os/linux/arm/Makefile src/os/linux/i386/Makefile src/os/linux/x86_64/Makefile src/os/linux/mips/Makefile src/os/linux/parisc/Makefile src/os/darwin/i386/Makefile src/os/darwin/powerpc/Makefile src/os/bsd/powerpc/Makefile src/os/bsd/arm/Makefile src/os/bsd/i386/Makefile src/os/bsd/x86_64/Makefile lib/Makefile lib/java/Makefile lib/java/lang/Makefile lib/jamvm/Makefile lib/jamvm/java/Makefile lib/jamvm/java/lang/Makefile lib/java/lang/reflect/Makefile lib/java/security/Makefile lib/gnu/Makefile lib/gnu/classpath/Makefile"
- cat >confcache <<\_ACEOF
-@@ -23537,6 +23538,7 @@
-   "src/os/linux/i386/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/i386/Makefile" ;;
-   "src/os/linux/x86_64/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/x86_64/Makefile" ;;
-   "src/os/linux/parisc/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/parisc/Makefile" ;;
-+  "src/os/linux/mips/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/mips/Makefile" ;;
-   "src/os/darwin/i386/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/darwin/i386/Makefile" ;;
-   "src/os/darwin/powerpc/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/darwin/powerpc/Makefile" ;;
-   "src/os/bsd/powerpc/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/bsd/powerpc/Makefile" ;;
-diff -ruN jamvm-1.4.4-old/configure.ac jamvm-1.4.4-new/configure.ac
---- jamvm-1.4.4-old/configure.ac       2006-12-18 15:31:28.000000000 +0100
-+++ jamvm-1.4.4-new/configure.ac       2006-12-18 15:31:59.000000000 +0100
-@@ -15,6 +15,7 @@
- hppa*-*-linux*) host_cpu=parisc host_os=linux ;;
- amd64-*-openbsd*) host_os=bsd libdl_needed=no ;;
- amd64-*-freebsd*) host_os=bsd libdl_needed=no ;;
-+mips*-linux*) host_cpu=mips host_os=linux ;;
- arm*-*-linux*) host_cpu=arm host_os=linux ;;
- arm*-*-openbsd*) host_cpu=arm host_os=bsd libdl_needed=no ;;
- arm*-*-freebsd*) host_cpu=arm host_os=bsd libdl_needed=no ;;
-@@ -229,6 +230,7 @@
-     src/os/linux/i386/Makefile \
-     src/os/linux/x86_64/Makefile \
-     src/os/linux/parisc/Makefile \
-+    src/os/linux/mips/Makefile \
-     src/os/darwin/i386/Makefile \
-     src/os/darwin/powerpc/Makefile \
-     src/os/bsd/powerpc/Makefile \
-diff -ruN jamvm-1.4.4-old/src/arch/Makefile.am jamvm-1.4.4-new/src/arch/Makefile.am
---- jamvm-1.4.4-old/src/arch/Makefile.am       2006-12-18 15:31:28.000000000 +0100
-+++ jamvm-1.4.4-new/src/arch/Makefile.am       2006-12-18 15:31:59.000000000 +0100
-@@ -1,3 +1,3 @@
- # used by automake to generate Makefile.in
--EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h parisc.h
-+EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h parisc.h mips.h
-diff -ruN jamvm-1.4.4-old/src/arch/Makefile.in jamvm-1.4.4-new/src/arch/Makefile.in
---- jamvm-1.4.4-old/src/arch/Makefile.in       2006-12-18 15:31:28.000000000 +0100
-+++ jamvm-1.4.4-new/src/arch/Makefile.in       2006-12-18 15:31:59.000000000 +0100
-@@ -158,7 +158,7 @@
- use_zip_no = @use_zip_no@
- use_zip_yes = @use_zip_yes@
- with_classpath_install_dir = @with_classpath_install_dir@
--EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h parisc.h
-+EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h parisc.h mips.h
- all: all-am
- .SUFFIXES:
-diff -ruN jamvm-1.4.4-old/src/arch/mips.h jamvm-1.4.4-new/src/arch/mips.h
---- jamvm-1.4.4-old/src/arch/mips.h    1970-01-01 01:00:00.000000000 +0100
-+++ jamvm-1.4.4-new/src/arch/mips.h    2006-12-18 15:31:59.000000000 +0100
-@@ -0,0 +1,69 @@
-+/*
-+ * Copyright (C) 2003, 2004, 2005 Robert Lougher <rob@lougher.demon.co.uk>.
-+ *
-+ * This file is part of JamVM.
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * as published by the Free Software Foundation; either version 2,
-+ * or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-+ */
-+
-+#define OS_ARCH "mips"
-+
-+#include <bits/atomicity.h>
-+
-+/* Override default min and max heap sizes.  mips machines are
-+   usually embedded, and the standard defaults are too large. */
-+#define DEFAULT_MAX_HEAP 16*MB
-+#define DEFAULT_MIN_HEAP 1*MB
-+
-+#ifdef DIRECT
-+#define HANDLER_TABLE_T static const void
-+#else
-+#define HANDLER_TABLE_T void
-+#endif
-+
-+#if defined(__MIPSEL__)
-+#define DOUBLE_1_BITS 0x3ff0000000000000LL
-+#else
-+#error  DOUBLE_1_BITS was not tested on a big endian mips!
-+#define DOUBLE_1_BITS 0x000000003ff00000LL
-+#endif
-+
-+#if  defined(__MIPSEL__)
-+#define READ_DBL(v,p,l)       v = ((u8)p[0]<<56)|((u8)p[1]<<48)|((u8)p[2]<<40) \
-+                            |((u8)p[3]<<32)|((u8)p[4]<<24)|((u8)p[5]<<16) \
-+                            |((u8)p[6]<<8)|(u8)p[7]; p+=8
-+#else
-+#error  READ_DBL was not tested on a big endian mips!
-+#define READ_DBL(v,p,l)       v = ((u8)p[4]<<56)|((u8)p[5]<<48)|((u8)p[6]<<40) \
-+                            |((u8)p[7]<<32)|((u8)p[0]<<24)|((u8)p[1]<<16) \
-+                            |((u8)p[2]<<8)|(u8)p[3]; p+=8
-+#endif
-+
-+/* Needed for i386 -- empty here */
-+#define FPU_HACK
-+
-+#define COMPARE_AND_SWAP(addr, old_val, new_val) compare_and_swap(addr,old_val,new_val)
-+
-+
-+#define ATOMIC_READ(addr) *addr
-+#define ATOMIC_WRITE(addr, new_val) *addr = new_val
-+
-+
-+
-+#define MBARRIER() __asm__ __volatile__ ("" ::: "memory")
-+#define UNLOCK_MBARRIER() __asm__ __volatile__ ("" ::: "memory")
-+#define JMM_LOCK_MBARRIER() __asm__ __volatile__ ("" ::: "memory")
-+#define JMM_UNLOCK_MBARRIER() __asm__ __volatile__ ("" ::: "memory")
-+
-diff -ruN jamvm-1.4.4-old/src/os/linux/Makefile.am jamvm-1.4.4-new/src/os/linux/Makefile.am
---- jamvm-1.4.4-old/src/os/linux/Makefile.am   2006-12-18 15:31:28.000000000 +0100
-+++ jamvm-1.4.4-new/src/os/linux/Makefile.am   2006-12-18 15:31:59.000000000 +0100
-@@ -1,5 +1,5 @@
- SUBDIRS = @arch@
--DIST_SUBDIRS = powerpc arm i386 x86_64 parisc
-+DIST_SUBDIRS = powerpc arm i386 x86_64 parisc mips
- noinst_LTLIBRARIES = libos.la
- libos_la_SOURCES = os.c
-diff -ruN jamvm-1.4.4-old/src/os/linux/Makefile.in jamvm-1.4.4-new/src/os/linux/Makefile.in
---- jamvm-1.4.4-old/src/os/linux/Makefile.in   2006-12-18 15:31:28.000000000 +0100
-+++ jamvm-1.4.4-new/src/os/linux/Makefile.in   2006-12-18 15:31:59.000000000 +0100
-@@ -181,7 +181,7 @@
- use_zip_yes = @use_zip_yes@
- with_classpath_install_dir = @with_classpath_install_dir@
- SUBDIRS = @arch@
--DIST_SUBDIRS = powerpc arm i386 x86_64 parisc
-+DIST_SUBDIRS = powerpc arm i386 x86_64 parisc mips
- noinst_LTLIBRARIES = libos.la
- libos_la_SOURCES = os.c
- AM_CPPFLAGS = -I$(top_builddir)/src
-diff -ruN jamvm-1.4.4-old/src/os/linux/mips/Makefile.am jamvm-1.4.4-new/src/os/linux/mips/Makefile.am
---- jamvm-1.4.4-old/src/os/linux/mips/Makefile.am      1970-01-01 01:00:00.000000000 +0100
-+++ jamvm-1.4.4-new/src/os/linux/mips/Makefile.am      2006-12-18 15:36:03.000000000 +0100
-@@ -0,0 +1,4 @@
-+noinst_LTLIBRARIES = libnative.la
-+libnative_la_SOURCES = init.c
-+
-+AM_CPPFLAGS = -I$(top_builddir)/src
-diff -ruN jamvm-1.4.4-old/src/os/linux/mips/Makefile.in jamvm-1.4.4-new/src/os/linux/mips/Makefile.in
---- jamvm-1.4.4-old/src/os/linux/mips/Makefile.in      1970-01-01 01:00:00.000000000 +0100
-+++ jamvm-1.4.4-new/src/os/linux/mips/Makefile.in      2006-12-18 15:49:53.000000000 +0100
-@@ -0,0 +1,432 @@
-+# Makefile.in generated by automake 1.9.6 from Makefile.am.
-+# @configure_input@
-+
-+# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-+# 2003, 2004, 2005  Free Software Foundation, Inc.
-+# This Makefile.in is free software; the Free Software Foundation
-+# gives unlimited permission to copy and/or distribute it,
-+# with or without modifications, as long as this notice is preserved.
-+
-+# This program is distributed in the hope that it will be useful,
-+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
-+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
-+# PARTICULAR PURPOSE.
-+
-+@SET_MAKE@
-+
-+srcdir = @srcdir@
-+top_srcdir = @top_srcdir@
-+VPATH = @srcdir@
-+pkgdatadir = $(datadir)/@PACKAGE@
-+pkglibdir = $(libdir)/@PACKAGE@
-+pkgincludedir = $(includedir)/@PACKAGE@
-+top_builddir = ../../../..
-+am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
-+INSTALL = @INSTALL@
-+install_sh_DATA = $(install_sh) -c -m 644
-+install_sh_PROGRAM = $(install_sh) -c
-+install_sh_SCRIPT = $(install_sh) -c
-+INSTALL_HEADER = $(INSTALL_DATA)
-+transform = $(program_transform_name)
-+NORMAL_INSTALL = :
-+PRE_INSTALL = :
-+POST_INSTALL = :
-+NORMAL_UNINSTALL = :
-+PRE_UNINSTALL = :
-+POST_UNINSTALL = :
-+build_triplet = @build@
-+host_triplet = @host@
-+subdir = src/os/linux/mips
-+DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
-+ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-+am__aclocal_m4_deps = $(top_srcdir)/acinclude.m4 \
-+      $(top_srcdir)/configure.ac
-+am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
-+      $(ACLOCAL_M4)
-+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
-+CONFIG_HEADER = $(top_builddir)/src/config.h
-+CONFIG_CLEAN_FILES =
-+LTLIBRARIES = $(noinst_LTLIBRARIES)
-+libnative_la_LIBADD =
-+am_libnative_la_OBJECTS = init.lo
-+libnative_la_OBJECTS = $(am_libnative_la_OBJECTS)
-+DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)/src
-+depcomp = $(SHELL) $(top_srcdir)/depcomp
-+am__depfiles_maybe = depfiles
-+COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
-+      $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-+LTCOMPILE = $(LIBTOOL) --tag=CC --mode=compile $(CC) $(DEFS) \
-+      $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
-+      $(AM_CFLAGS) $(CFLAGS)
-+CCLD = $(CC)
-+LINK = $(LIBTOOL) --tag=CC --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-+      $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+SOURCES = $(libnative_la_SOURCES)
-+DIST_SOURCES = $(libnative_la_SOURCES)
-+ETAGS = etags
-+CTAGS = ctags
-+DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
-+ACLOCAL = @ACLOCAL@
-+ALLOCA = @ALLOCA@
-+AMDEP_FALSE = @AMDEP_FALSE@
-+AMDEP_TRUE = @AMDEP_TRUE@
-+AMTAR = @AMTAR@
-+AR = @AR@
-+AUTOCONF = @AUTOCONF@
-+AUTOHEADER = @AUTOHEADER@
-+AUTOMAKE = @AUTOMAKE@
-+AWK = @AWK@
-+CC = @CC@
-+CCAS = @CCAS@
-+CCASFLAGS = @CCASFLAGS@
-+CCDEPMODE = @CCDEPMODE@
-+CFLAGS = @CFLAGS@
-+CPP = @CPP@
-+CPPFLAGS = @CPPFLAGS@
-+CXX = @CXX@
-+CXXCPP = @CXXCPP@
-+CXXDEPMODE = @CXXDEPMODE@
-+CXXFLAGS = @CXXFLAGS@
-+CYGPATH_W = @CYGPATH_W@
-+DEFS = @DEFS@
-+DEPDIR = @DEPDIR@
-+ECHO = @ECHO@
-+ECHO_C = @ECHO_C@
-+ECHO_N = @ECHO_N@
-+ECHO_T = @ECHO_T@
-+EGREP = @EGREP@
-+EXEEXT = @EXEEXT@
-+F77 = @F77@
-+FFLAGS = @FFLAGS@
-+INSTALL_DATA = @INSTALL_DATA@
-+INSTALL_PROGRAM = @INSTALL_PROGRAM@
-+INSTALL_SCRIPT = @INSTALL_SCRIPT@
-+INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
-+JAVAC = @JAVAC@
-+LDFLAGS = @LDFLAGS@
-+LIBOBJS = @LIBOBJS@
-+LIBS = @LIBS@
-+LIBTOOL = @LIBTOOL@
-+LN_S = @LN_S@
-+LTLIBOBJS = @LTLIBOBJS@
-+MAINT = @MAINT@
-+MAINTAINER_MODE_FALSE = @MAINTAINER_MODE_FALSE@
-+MAINTAINER_MODE_TRUE = @MAINTAINER_MODE_TRUE@
-+MAKEINFO = @MAKEINFO@
-+OBJEXT = @OBJEXT@
-+PACKAGE = @PACKAGE@
-+PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
-+PACKAGE_NAME = @PACKAGE_NAME@
-+PACKAGE_STRING = @PACKAGE_STRING@
-+PACKAGE_TARNAME = @PACKAGE_TARNAME@
-+PACKAGE_VERSION = @PACKAGE_VERSION@
-+PATH_SEPARATOR = @PATH_SEPARATOR@
-+RANLIB = @RANLIB@
-+SET_MAKE = @SET_MAKE@
-+SHELL = @SHELL@
-+STRIP = @STRIP@
-+VERSION = @VERSION@
-+ac_ct_AR = @ac_ct_AR@
-+ac_ct_CC = @ac_ct_CC@
-+ac_ct_CXX = @ac_ct_CXX@
-+ac_ct_F77 = @ac_ct_F77@
-+ac_ct_RANLIB = @ac_ct_RANLIB@
-+ac_ct_STRIP = @ac_ct_STRIP@
-+am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
-+am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
-+am__fastdepCXX_FALSE = @am__fastdepCXX_FALSE@
-+am__fastdepCXX_TRUE = @am__fastdepCXX_TRUE@
-+am__include = @am__include@
-+am__leading_dot = @am__leading_dot@
-+am__quote = @am__quote@
-+am__tar = @am__tar@
-+am__untar = @am__untar@
-+arch = @arch@
-+bindir = @bindir@
-+build = @build@
-+build_alias = @build_alias@
-+build_cpu = @build_cpu@
-+build_os = @build_os@
-+build_vendor = @build_vendor@
-+datadir = @datadir@
-+exec_prefix = @exec_prefix@
-+host = @host@
-+host_alias = @host_alias@
-+host_cpu = @host_cpu@
-+host_os = @host_os@
-+host_vendor = @host_vendor@
-+includedir = @includedir@
-+infodir = @infodir@
-+install_sh = @install_sh@
-+libdir = @libdir@
-+libexecdir = @libexecdir@
-+localstatedir = @localstatedir@
-+mandir = @mandir@
-+mkdir_p = @mkdir_p@
-+oldincludedir = @oldincludedir@
-+os = @os@
-+prefix = @prefix@
-+program_transform_name = @program_transform_name@
-+sbindir = @sbindir@
-+sharedstatedir = @sharedstatedir@
-+sysconfdir = @sysconfdir@
-+target_alias = @target_alias@
-+use_zip_no = @use_zip_no@
-+use_zip_yes = @use_zip_yes@
-+with_classpath_install_dir = @with_classpath_install_dir@
-+noinst_LTLIBRARIES = libnative.la
-+libnative_la_SOURCES = init.c
-+AM_CPPFLAGS = -I$(top_builddir)/src
-+all: all-am
-+
-+.SUFFIXES:
-+.SUFFIXES: .c .lo .o .obj
-+$(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am  $(am__configure_deps)
-+      @for dep in $?; do \
-+        case '$(am__configure_deps)' in \
-+          *$$dep*) \
-+            cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh \
-+              && exit 0; \
-+            exit 1;; \
-+        esac; \
-+      done; \
-+      echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu  src/os/linux/mips/Makefile'; \
-+      cd $(top_srcdir) && \
-+        $(AUTOMAKE) --gnu  src/os/linux/mips/Makefile
-+.PRECIOUS: Makefile
-+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
-+      @case '$?' in \
-+        *config.status*) \
-+          cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh;; \
-+        *) \
-+          echo ' cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)'; \
-+          cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe);; \
-+      esac;
-+
-+$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
-+      cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
-+
-+$(top_srcdir)/configure: @MAINTAINER_MODE_TRUE@ $(am__configure_deps)
-+      cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
-+$(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(am__aclocal_m4_deps)
-+      cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
-+
-+clean-noinstLTLIBRARIES:
-+      -test -z "$(noinst_LTLIBRARIES)" || rm -f $(noinst_LTLIBRARIES)
-+      @list='$(noinst_LTLIBRARIES)'; for p in $$list; do \
-+        dir="`echo $$p | sed -e 's|/[^/]*$$||'`"; \
-+        test "$$dir" != "$$p" || dir=.; \
-+        echo "rm -f \"$${dir}/so_locations\""; \
-+        rm -f "$${dir}/so_locations"; \
-+      done
-+libnative.la: $(libnative_la_OBJECTS) $(libnative_la_DEPENDENCIES) 
-+      $(LINK)  $(libnative_la_LDFLAGS) $(libnative_la_OBJECTS) $(libnative_la_LIBADD) $(LIBS)
-+
-+mostlyclean-compile:
-+      -rm -f *.$(OBJEXT)
-+
-+distclean-compile:
-+      -rm -f *.tab.c
-+
-+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/init.Plo@am__quote@
-+
-+.c.o:
-+@am__fastdepCC_TRUE@  if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; \
-+@am__fastdepCC_TRUE@  then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
-+@AMDEP_TRUE@@am__fastdepCC_FALSE@     source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
-+@AMDEP_TRUE@@am__fastdepCC_FALSE@     DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-+@am__fastdepCC_FALSE@ $(COMPILE) -c $<
-+
-+.c.obj:
-+@am__fastdepCC_TRUE@  if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ `$(CYGPATH_W) '$<'`; \
-+@am__fastdepCC_TRUE@  then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
-+@AMDEP_TRUE@@am__fastdepCC_FALSE@     source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
-+@AMDEP_TRUE@@am__fastdepCC_FALSE@     DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-+@am__fastdepCC_FALSE@ $(COMPILE) -c `$(CYGPATH_W) '$<'`
-+
-+.c.lo:
-+@am__fastdepCC_TRUE@  if $(LTCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; \
-+@am__fastdepCC_TRUE@  then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Plo"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
-+@AMDEP_TRUE@@am__fastdepCC_FALSE@     source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
-+@AMDEP_TRUE@@am__fastdepCC_FALSE@     DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-+@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
-+
-+mostlyclean-libtool:
-+      -rm -f *.lo
-+
-+clean-libtool:
-+      -rm -rf .libs _libs
-+
-+distclean-libtool:
-+      -rm -f libtool
-+uninstall-info-am:
-+
-+ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
-+      list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
-+      unique=`for i in $$list; do \
-+          if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
-+        done | \
-+        $(AWK) '    { files[$$0] = 1; } \
-+             END { for (i in files) print i; }'`; \
-+      mkid -fID $$unique
-+tags: TAGS
-+
-+TAGS:  $(HEADERS) $(SOURCES)  $(TAGS_DEPENDENCIES) \
-+              $(TAGS_FILES) $(LISP)
-+      tags=; \
-+      here=`pwd`; \
-+      list='$(SOURCES) $(HEADERS)  $(LISP) $(TAGS_FILES)'; \
-+      unique=`for i in $$list; do \
-+          if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
-+        done | \
-+        $(AWK) '    { files[$$0] = 1; } \
-+             END { for (i in files) print i; }'`; \
-+      if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
-+        test -n "$$unique" || unique=$$empty_fix; \
-+        $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
-+          $$tags $$unique; \
-+      fi
-+ctags: CTAGS
-+CTAGS:  $(HEADERS) $(SOURCES)  $(TAGS_DEPENDENCIES) \
-+              $(TAGS_FILES) $(LISP)
-+      tags=; \
-+      here=`pwd`; \
-+      list='$(SOURCES) $(HEADERS)  $(LISP) $(TAGS_FILES)'; \
-+      unique=`for i in $$list; do \
-+          if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
-+        done | \
-+        $(AWK) '    { files[$$0] = 1; } \
-+             END { for (i in files) print i; }'`; \
-+      test -z "$(CTAGS_ARGS)$$tags$$unique" \
-+        || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
-+           $$tags $$unique
-+
-+GTAGS:
-+      here=`$(am__cd) $(top_builddir) && pwd` \
-+        && cd $(top_srcdir) \
-+        && gtags -i $(GTAGS_ARGS) $$here
-+
-+distclean-tags:
-+      -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
-+
-+distdir: $(DISTFILES)
-+      @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
-+      topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
-+      list='$(DISTFILES)'; for file in $$list; do \
-+        case $$file in \
-+          $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
-+          $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
-+        esac; \
-+        if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
-+        dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
-+        if test "$$dir" != "$$file" && test "$$dir" != "."; then \
-+          dir="/$$dir"; \
-+          $(mkdir_p) "$(distdir)$$dir"; \
-+        else \
-+          dir=''; \
-+        fi; \
-+        if test -d $$d/$$file; then \
-+          if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
-+            cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
-+          fi; \
-+          cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
-+        else \
-+          test -f $(distdir)/$$file \
-+          || cp -p $$d/$$file $(distdir)/$$file \
-+          || exit 1; \
-+        fi; \
-+      done
-+check-am: all-am
-+check: check-am
-+all-am: Makefile $(LTLIBRARIES)
-+installdirs:
-+install: install-am
-+install-exec: install-exec-am
-+install-data: install-data-am
-+uninstall: uninstall-am
-+
-+install-am: all-am
-+      @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
-+
-+installcheck: installcheck-am
-+install-strip:
-+      $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
-+        install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
-+        `test -z '$(STRIP)' || \
-+          echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
-+mostlyclean-generic:
-+
-+clean-generic:
-+
-+distclean-generic:
-+      -test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
-+
-+maintainer-clean-generic:
-+      @echo "This command is intended for maintainers to use"
-+      @echo "it deletes files that may require special tools to rebuild."
-+clean: clean-am
-+
-+clean-am: clean-generic clean-libtool clean-noinstLTLIBRARIES \
-+      mostlyclean-am
-+
-+distclean: distclean-am
-+      -rm -rf ./$(DEPDIR)
-+      -rm -f Makefile
-+distclean-am: clean-am distclean-compile distclean-generic \
-+      distclean-libtool distclean-tags
-+
-+dvi: dvi-am
-+
-+dvi-am:
-+
-+html: html-am
-+
-+info: info-am
-+
-+info-am:
-+
-+install-data-am:
-+
-+install-exec-am:
-+
-+install-info: install-info-am
-+
-+install-man:
-+
-+installcheck-am:
-+
-+maintainer-clean: maintainer-clean-am
-+      -rm -rf ./$(DEPDIR)
-+      -rm -f Makefile
-+maintainer-clean-am: distclean-am maintainer-clean-generic
-+
-+mostlyclean: mostlyclean-am
-+
-+mostlyclean-am: mostlyclean-compile mostlyclean-generic \
-+      mostlyclean-libtool
-+
-+pdf: pdf-am
-+
-+pdf-am:
-+
-+ps: ps-am
-+
-+ps-am:
-+
-+uninstall-am: uninstall-info-am
-+
-+.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
-+      clean-libtool clean-noinstLTLIBRARIES ctags distclean \
-+      distclean-compile distclean-generic distclean-libtool \
-+      distclean-tags distdir dvi dvi-am html html-am info info-am \
-+      install install-am install-data install-data-am install-exec \
-+      install-exec-am install-info install-info-am install-man \
-+      install-strip installcheck installcheck-am installdirs \
-+      maintainer-clean maintainer-clean-generic mostlyclean \
-+      mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
-+      pdf pdf-am ps ps-am tags uninstall uninstall-am \
-+      uninstall-info-am
-+
-+# Tell versions [3.59,3.63) of GNU make to not export all variables.
-+# Otherwise a system limit (for SysV at least) may be exceeded.
-+.NOEXPORT:
-diff -ruN jamvm-1.4.4-old/src/os/linux/mips/init.c jamvm-1.4.4-new/src/os/linux/mips/init.c
---- jamvm-1.4.4-old/src/os/linux/mips/init.c   1970-01-01 01:00:00.000000000 +0100
-+++ jamvm-1.4.4-new/src/os/linux/mips/init.c   2006-12-18 15:31:59.000000000 +0100
-@@ -0,0 +1,23 @@
-+/*
-+ * Copyright (C) 2003, 2004 Robert Lougher <rob@lougher.demon.co.uk>.
-+ *
-+ * This file is part of JamVM.
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * as published by the Free Software Foundation; either version 2,
-+ * or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-+ */
-+
-+void initialisePlatform() {
-+    /* Nothing to do for mips */
-+}
diff --git a/lang/jamvm/patches/200-pthread_hacks.patch b/lang/jamvm/patches/200-pthread_hacks.patch
deleted file mode 100644 (file)
index f1908f3..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- jamvm-1.4.4/src/os/linux/os.c      2006-10-29 23:56:43.000000000 +0100
-+++ jamvm-1.4.4.new/src/os/linux/os.c  2006-12-09 21:17:43.000000000 +0100
-@@ -31,15 +31,18 @@
-     pthread_attr_t attr;
-     void *addr;
-     int size;
--
-+#if 0
-+/* Not implemented in uClibc yet */
-     pthread_getattr_np(pthread_self(), &attr);
--    pthread_attr_getstack(&attr, &addr, &size);
-+#endif
-+    pthread_attr_getstackaddr(&attr, &addr);
-     return addr+size;
- }
- int nativeAvailableProcessors() {
--    return get_nprocs();
-+/* We assume embedded systems concerned are mono-processor only */
-+    return 1;
- }
- char *nativeLibPath() {