sunxi: respect CONFIG_TARGET_IMAGES_GZIP
authorZoltan Herpai <wigyori@uid0.hu>
Sat, 15 Aug 2015 15:10:14 +0000 (15:10 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Sat, 15 Aug 2015 15:10:14 +0000 (15:10 +0000)
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 46608

target/linux/sunxi/image/Makefile

index 10d2200aa3ce510322151a9e8280e1c05fa107b7..5a5c98a7c03625a79efcd80bbc10f9b4cdcbbd71 100644 (file)
@@ -45,6 +45,10 @@ define Image/Build/SDCard
                $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
                $(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
+
+  ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+       gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img
+  endif
 endef
 
 define Image/Build/Profile/A10-OLinuXino-Lime