ar71xx: add kernel support for the My Net Wi-Fi Range Extender device
authorGabor Juhos <juhosg@openwrt.org>
Thu, 7 Nov 2013 22:31:52 +0000 (22:31 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 7 Nov 2013 22:31:52 +0000 (22:31 +0000)
This patch adds a new device definition for a
Western Digital device. The hardware seems to
be based on Qualcomm Atheros DB120 design.

Patchwork: http://patchwork.openwrt.org/patch/4281/
Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
[juhosg: refresh kernel patch]
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38686

target/linux/ar71xx/config-3.10
target/linux/ar71xx/files/arch/mips/ath79/mach-mynet-rext.c [new file with mode: 0644]
target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch [new file with mode: 0644]

index f0b45f86173f5189ab20175300ba3178de6d1aa4..d924c59996d1a73f14a912d0cad693a81ee80f14 100644 (file)
@@ -52,6 +52,7 @@ CONFIG_ATH79_MACH_JA76PF=y
 CONFIG_ATH79_MACH_JWAP003=y
 CONFIG_ATH79_MACH_MR600=y
 CONFIG_ATH79_MACH_MYNET_N600=y
+CONFIG_ATH79_MACH_MYNET_REXT=y
 CONFIG_ATH79_MACH_MZK_W04NU=y
 CONFIG_ATH79_MACH_MZK_W300NH=y
 CONFIG_ATH79_MACH_NBG460N=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-mynet-rext.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-mynet-rext.c
new file mode 100644 (file)
index 0000000..d20dbe0
--- /dev/null
@@ -0,0 +1,175 @@
+/*
+ *  WD My Net WI-FI Range Extender (Codename:Starfish db12x) board support
+ *
+ *  Copyright (C) 2013 Christian Lamparter <chunkeey@googlemail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/pci.h>
+#include <linux/phy.h>
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "nvram.h"
+
+#define MYNET_REXT_GPIO_LED_POWER      11
+#define MYNET_REXT_GPIO_LED_ETHERNET   12
+#define MYNET_REXT_GPIO_LED_WIFI       19
+
+#define MYNET_REXT_GPIO_LED_RF_QTY1    20
+#define MYNET_REXT_GPIO_LED_RF_QTY2    21
+#define MYNET_REXT_GPIO_LED_RF_QTY3    22
+
+#define MYNET_REXT_GPIO_BTN_RESET      13
+#define MYNET_REXT_GPIO_BTN_WPS                15
+#define MYNET_REXT_GPIO_SW_RF          14
+
+#define MYNET_REXT_GPIO_PHY_SWRST      16      /* disables Ethernet PHY */
+#define MYNET_REXT_GPIO_PHY_INT                17
+#define MYNET_REXT_GPIO_18             18
+
+#define MYNET_REXT_KEYS_POLL_INTERVAL  20      /* msecs */
+#define MYNET_REXT_KEYS_DEBOUNCE_INTERVAL (3 * MYNET_REXT_KEYS_POLL_INTERVAL)
+
+#define MYNET_REXT_WMAC_CALDATA_OFFSET 0x1000
+
+#define MYNET_REXT_NVRAM_ADDR          0x1f7e0010
+#define MYNET_REXT_NVRAM_SIZE          0xfff0
+
+#define MYNET_REXT_ART_ADDR            0x1f7f0000
+
+static struct gpio_led mynet_rext_leds_gpio[] __initdata = {
+       {
+               .name           = "wd:blue:power",
+               .gpio           = MYNET_REXT_GPIO_LED_POWER,
+               .active_low     = 0,
+       },
+       {
+               .name           = "wd:blue:wireless",
+               .gpio           = MYNET_REXT_GPIO_LED_WIFI,
+               .active_low     = 1,
+       },
+       {
+               .name           = "wd:blue:ethernet",
+               .gpio           = MYNET_REXT_GPIO_LED_ETHERNET,
+               .active_low     = 1,
+       },
+       {
+               .name           = "wd:blue:quality1",
+               .gpio           = MYNET_REXT_GPIO_LED_RF_QTY1,
+               .active_low     = 1,
+       },
+       {
+               .name           = "wd:blue:quality2",
+               .gpio           = MYNET_REXT_GPIO_LED_RF_QTY2,
+               .active_low     = 1,
+       },
+       {
+               .name           = "wd:blue:quality3",
+               .gpio           = MYNET_REXT_GPIO_LED_RF_QTY3,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button mynet_rext_gpio_keys[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = MYNET_REXT_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = MYNET_REXT_GPIO_BTN_RESET,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "WPS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = MYNET_REXT_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = MYNET_REXT_GPIO_BTN_WPS,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "RF Band switch",
+               .type           = EV_SW,
+               .code           = BTN_1,
+               .debounce_interval = MYNET_REXT_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = MYNET_REXT_GPIO_SW_RF,
+       },
+};
+
+static void mynet_rext_get_mac(const char *name, char *mac)
+{
+       u8 *nvram = (u8 *) KSEG1ADDR(MYNET_REXT_NVRAM_ADDR);
+       int err;
+
+       err = ath79_nvram_parse_mac_addr(nvram, MYNET_REXT_NVRAM_SIZE,
+                                        name, mac);
+       if (err)
+               pr_err("no MAC address found for %s\n", name);
+}
+
+static void __init mynet_rext_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(MYNET_REXT_ART_ADDR);
+       u8 tmpmac[ETH_ALEN];
+
+       ath79_register_m25p80(NULL);
+
+       /* GPIO configuration from drivers/char/GPIO8.c */
+
+       ath79_gpio_output_select(MYNET_REXT_GPIO_LED_POWER,
+                                AR934X_GPIO_OUT_GPIO);
+       ath79_gpio_output_select(MYNET_REXT_GPIO_LED_WIFI,
+                                AR934X_GPIO_OUT_GPIO);
+       ath79_gpio_output_select(MYNET_REXT_GPIO_LED_RF_QTY1,
+                                AR934X_GPIO_OUT_GPIO);
+       ath79_gpio_output_select(MYNET_REXT_GPIO_LED_RF_QTY2,
+                                AR934X_GPIO_OUT_GPIO);
+       ath79_gpio_output_select(MYNET_REXT_GPIO_LED_RF_QTY3,
+                                AR934X_GPIO_OUT_GPIO);
+       ath79_gpio_output_select(MYNET_REXT_GPIO_LED_ETHERNET,
+                                AR934X_GPIO_OUT_GPIO);
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(mynet_rext_leds_gpio),
+                                mynet_rext_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, MYNET_REXT_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(mynet_rext_gpio_keys),
+                                       mynet_rext_gpio_keys);
+
+       mynet_rext_get_mac("wl0_hwaddr=", tmpmac);
+       ath79_register_wmac(art + MYNET_REXT_WMAC_CALDATA_OFFSET, tmpmac);
+
+       ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_RGMII_GMAC0);
+
+       ath79_register_mdio(0, 0x0);
+
+       /* LAN */
+       mynet_rext_get_mac("et0macaddr=", ath79_eth0_data.mac_addr);
+
+       /* GMAC0 is connected to an external PHY on Port 4 */
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ath79_eth0_data.phy_mask = BIT(4);
+       ath79_eth0_pll_data.pll_1000 = 0x0e000000; /* athrs_mac.c */
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+       ath79_register_eth(0);
+}
+
+MIPS_MACHINE(ATH79_MACH_MYNET_REXT, "MYNET-REXT",
+            "WD My Net Wi-Fi Range Extender", mynet_rext_setup);
diff --git a/target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch b/target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch
new file mode 100644 (file)
index 0000000..dfbff45
--- /dev/null
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -56,6 +56,7 @@ enum ath79_mach_type {
+       ATH79_MACH_MR600V2,             /* OpenMesh MR600v2 */
+       ATH79_MACH_MR600,               /* OpenMesh MR600 */
+       ATH79_MACH_MYNET_N600,          /* WD My Net N600 */
++      ATH79_MACH_MYNET_REXT,          /* WD My Net Wi-Fi Range Extender */
+       ATH79_MACH_MZK_W04NU,           /* Planex MZK-W04NU */
+       ATH79_MACH_MZK_W300NH,          /* Planex MZK-W300NH */
+       ATH79_MACH_NBG460N,             /* Zyxel NBG460N/550N/550NH */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -67,6 +67,7 @@ obj-$(CONFIG_ATH79_MACH_JWAP003)     += mach
+ obj-$(CONFIG_ATH79_MACH_HORNET_UB)    += mach-hornet-ub.o
+ obj-$(CONFIG_ATH79_MACH_MR600)                += mach-mr600.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
++obj-$(CONFIG_ATH79_MACH_MYNET_REXT)   += mach-mynet-rext.o
+ obj-$(CONFIG_ATH79_MACH_MZK_W04NU)    += mach-mzk-w04nu.o
+ obj-$(CONFIG_ATH79_MACH_MZK_W300NH)   += mach-mzk-w300nh.o
+ obj-$(CONFIG_ATH79_MACH_NBG460N)      += mach-nbg460n.o
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -801,6 +801,16 @@ config ATH79_MACH_MYNET_N600
+       select ATH79_DEV_WMAC
+       select ATH79_NVRAM
++config ATH79_MACH_MYNET_REXT
++      bool "WD My Net Wi-Fi Range Extender board support"
++      select SOC_AR934X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_WMAC
++      select ATH79_NVRAM
++
+ config ATH79_MACH_ZCN_1523H
+       bool "Zcomax ZCN-1523H support"
+       select SOC_AR724X