fix pdc20xx compile for linux 2.6
authorFelix Fietkau <nbd@openwrt.org>
Mon, 24 Aug 2009 00:52:00 +0000 (00:52 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 24 Aug 2009 00:52:00 +0000 (00:52 +0000)
SVN-Revision: 17359

package/kernel/modules/block.mk

index 3fa7b1c..09450bf 100644 (file)
@@ -254,12 +254,16 @@ $(eval $(call KernelPackage,ide-magicbox))
 define KernelPackage/ide-pdc202xx
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Promise PDC202xx IDE driver
-  DEPENDS:=@LINUX_2_4 +kmod-ide-core
+  DEPENDS:=+kmod-ide-core
   KCONFIG:=CONFIG_BLK_DEV_PDC202XX_OLD
-  FILES:=$(LINUX_DIR)/drivers/ide/pci/pdc202xx_old.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/ide/pdc202xx_old.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,pdc202xx_old)
 endef
 
+define KernelPackage/ide-pdc202xx/2.4
+  FILES:=$(LINUX_DIR)/drivers/ide/pci/pdc202xx_old.$(LINUX_KMOD_SUFFIX)
+endef
+
 define KernelPackage/ide-pdc202xx/description
  Support for the Promise Ultra 33/66/100 (PDC202{46|62|65|67|68}) IDE
  controllers.