[packages] libxslt: update to v1.1.26, cleanup
authorNicolas Thill <nico@openwrt.org>
Mon, 5 Oct 2009 15:45:10 +0000 (15:45 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 5 Oct 2009 15:45:10 +0000 (15:45 +0000)
SVN-Revision: 17891

libs/libxslt/Makefile

index a7fe928cfa9e326ee1479e94444a29d6b85ee881..4dce40224d073f8096b4730b7b9b458ff81ec524 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,19 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libxslt
-PKG_VERSION:=1.1.24
-PKG_RELEASE:=2
+PKG_VERSION:=1.1.26
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
        ftp://fr.rpmfind.net/pub/libxml/
-PKG_MD5SUM:=e83ec5d27fc4c10c6f612879bea9a153
+PKG_MD5SUM:=e61d0364a30146aaa3001296f853b2b9
+
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_INSTALL=1
-
 define Package/libxslt
   SECTION:=libs
   CATEGORY:=Libraries
@@ -45,17 +45,14 @@ define Package/xsltproc/description
        XSLT XML transformation utility
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --without-python \
-               --without-crypto \
-               --without-debug \
-               --without-mem-debug \
-               --without-debugger \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --without-python \
+       --without-crypto \
+       --without-debug \
+       --without-mem-debug \
+       --without-debugger \
 
 TARGET_CFLAGS += $(FPIC)