[package] base-files:
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 16 Jan 2010 13:39:13 +0000 (13:39 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 16 Jan 2010 13:39:13 +0000 (13:39 +0000)
sysupgade library coomon.sh has "bug" in glibc enviorement. For some reason
ld-linux.so.3 is not installed at ramfs and sysupgrade always fails.
Signed-off-by: Zintis Petersons <zintis.petersons@e-mail.lv>
SVN-Revision: 19167

package/base-files/Makefile
package/base-files/files/lib/upgrade/common.sh

index 67837120b67f7023dc48fac71694690f86377793..ea2b5a47f196adf842c82c503b73e8d1f2e88cd3 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=34
+PKG_RELEASE:=35
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index ff3012bcc1a2b47e9ded6b420fddc5761c732739..3beb6484d851f748debc1882d23123477e7d1a24 100644 (file)
@@ -21,6 +21,9 @@ install_bin() { # <file> [ <symlink> ... ]
        files=$1
        [ -x "$src" ] && files="$src $(libs $src)"
        install_file $files
+       [ -e /lib/ld-linux.so.3 ] && {
+               install_file /lib/ld-linux.so.3
+       }
        shift
        for link in "$@"; do {
                dest="$RAM_ROOT/$link"