Update acx-mac80211 to a more recent snapshot, thanks sn9
authorFlorian Fainelli <florian@openwrt.org>
Sat, 30 Aug 2008 12:25:38 +0000 (12:25 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 30 Aug 2008 12:25:38 +0000 (12:25 +0000)
SVN-Revision: 12439

package/acx-mac80211/Makefile
package/acx-mac80211/patches/001-build_module.diff

index 10865ab262536669dcc210c0ca1413ffa8141840..2fcf3a6f4e5ee0e85a229070d504d0c132424892 100644 (file)
@@ -10,12 +10,15 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx-mac80211
-PKG_VERSION:=20080210
+PKG_REV:=11edba2
+PKG_VERSION:=20080805
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/acx100
-PKG_MD5SUM:=d1c38b3ff24ce9162eb678298763ec88
+PKG_SOURCE_URL:=git://gitorious.org/acx-mac80211/mainline.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
 
 PKG_FW_C16_NAME:=tiacx111c16
 PKG_FW_C16_URL:=http://teknoraver.net/software/acx-mac80211/
index 3c1fcda33e46513d8bcc0ce4d54b73dfe400ddd3..38dd5901df02df090412906f92a10beec9716f43 100644 (file)
@@ -1,11 +1,11 @@
---- acx-mac80211-20070610/Makefile     2007-06-10 20:23:27.000000000 +0200
-+++ acx-mac80211-20070610//Makefile    2007-07-23 17:00:34.000000000 +0200
-@@ -4,7 +4,7 @@
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
- #acx-mac80211-objs := wlan.o conv.o ioctl.o common.o $(acx-mac80211-obj-y)
--acx-mac80211-objs :=  common.o $(acx-mac80211-obj-y)
-+acx-mac80211-objs :=  common.o $(acx-mac80211-obj-m)
- # Use this if you have proper Kconfig integration:
+--- acx-mac80211-20080802/Makefile     2008-08-02 17:34:09.000000000 +0200
++++ acx-mac80211-20080802-b/Makefile   2008-08-04 22:24:25.000000000 +0200
+@@ -28,7 +28,7 @@
      obj-$(CONFIG_ACX_MAC80211) += acx-mac80211.o
+       acx-mac80211-obj-$(CONFIG_ACX_MAC80211_PCI) += pci.o
+       acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
+-      acx-mac80211-objs := common.o $(acx-mac80211-obj-y)
++      acx-mac80211-objs := common.o $(acx-mac80211-obj-m)
+ else
+ # Otherwise we were called directly from the command line: the the kernel build
+ # system must be explicitly invoked.