ar71xx: rename firmware for Chinese version of TL-WR941ND v6
authorJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 08:14:59 +0000 (08:14 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 08:14:59 +0000 (08:14 +0000)
It seems there are two *different* versions on TL-WR941ND v6: Chinese
and European one. Currently supported by OpenWrt is Chinese one. Rename
firmware to make it clear.
For details see:
http://wiki.openwrt.org/toh/tp-link/tl-wr941nd
https://forum.openwrt.org/viewtopic.php?id=59295

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
Backport of r47107

SVN-Revision: 48859

target/linux/ar71xx/image/Makefile

index 05ef1d2d41166891ca7dc5ccb0b6cb3f5b95b667..24c60f58e320f441b3b18553c4280f9985eacc97 100644 (file)
@@ -598,13 +598,14 @@ define Device/tl-wr941nd-v5
     TPLINK_HWID := 0x09410005
 endef
 
-define Device/tl-wr941nd-v6
+# Chinese version (unlike European) is similar to the TL-WDR3500
+define Device/tl-wr941nd-v6-cn
     $(Device/tplink-4mlzma)
     BOARDNAME := TL-WDR3500
     DEVICE_PROFILE := TLWR941
     TPLINK_HWID := 0x09410006
 endef
-TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6
+TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6-cn
 
 define Device/tl-wr1041n-v2
     $(Device/tplink-4mlzma)